Update 0.85.2 on RPi/Prusa Anet unusable [SOLVED]

edited July 2017 in Bug Reports
I have updated today my Repetier-Server Pro software from 0.80.3 to 0.85.2 on my RPi and ... it is unusable !
- Very very very slow
- Impossible to switch between groups. Only the default group is displayed and the GroupComboBox stays empty
- When launching a printing : only the message which says that the printing is preparing ... but nothing else

Is it possible to downgrade returning to the previous version (0.80.3 for me) keeping all my groups and g-code files with a standard installation procedure such as :  sudo dpkg -i Repetier-Server-0.80.3-Linux.deb ?


EDIT : I've tried, it seems it does :-) :

root@RepetierServer:/home/pi# dpkg -i Repetier-Server-0.80.3-Linux.deb
dpkg: warning: downgrading repetier-server from 0.85.2 to 0.80.3
(Reading database ... 46483 files and directories currently installed.)
Preparing to unpack Repetier-Server-0.80.3-Linux.deb ...
Uninstall Repetier-Server
Removed symlink /etc/systemd/system/multi-user.target.wants/RepetierServer.service.
Unpacking repetier-server (0.80.3) over (0.85.2) ...
Setting up repetier-server (0.80.3) ...
Install Repetier-Server
You may see warnings about groups. These can be ignored.
The user `repetierserver' is already a member of `tty'.
adduser: The group `intserial' does not exist.
adduser: The group `ugpio' does not exist.
Created symlink from /etc/systemd/system/multi-user.target.wants/RepetierServer.service to /lib/systemd/system/RepetierServer.service.
Processing triggers for systemd (215-17+deb8u7) ...

Unfortunately, the symptoms are the same now with the previous version reinstalled : very slow, GroupComboBox empty, freezing printings ! Perhaps, when upgrading or downgrading, the g-code files scan takes a while ? (I have 10 groups with hundreds of 3D files)

I will wait one day before using my Repetier-Server to confirm (or not).

No need to wait a whole day : within 15 minutes, the release 0.80.3 works fine again !


  • 0.85.2 is not slow, but it has some new features requiring to parse all g-code files. So after upgrading it rescans all g-code files (which 0.80.3 did then finish). If you would not have switched back everything would be normal again.

    It is just having hundreds of files takes just a bit longer to update.
  • Ok, I have understood what is happended with my hundreds of g-code files !
    Thank you for your quick answer ! Then, I will re-update to 0.85.2 and wait a long time before using it ! :-)

  • edited July 2017
    I confirm ! After few hours scanning and parsing my hundreds files, all is okay ! It's printing ! All works fine !
    Thank you! :-)

    The title of this subject may be changed to "Solved"
Sign In or Register to comment.