Can any one get repetier working or not? why no fixs?

Because im searching like mad and Im yet to see some one post a fix. And icve searched so hard all I get is same forums "here" with no fixs.
Bit annoying specially when its something thats come pre installed in a machine and dont work.

Heres my problem.

Manual control not working or works intermittent. Like a zillion others have reported. My machine hasnt worked from new.

Seems like missing commands to me but im a newb. "repetier host manual control." 0.1mm will make it make extruder do 178.89mph north and thats using my lcd position to move the extruder before it burns its self out. Manual control just wont work on extruder regardless of what I do.

Ive just about done everything and looking to reflash with something else as its been 3months and more and I cant use it. This was suppose to work out the box.

Has repetier 0.91 x1.2 v1.1 installed.

Theres a play list there.
Its stupid.
My extruder motor and driver will go mad hot unless I use the lcd to move E threw position.
Then it will spin like mad or work but repetier host will not do nothing.

When I home X it can send Y spinning like mad. I can also do 0.1 left and it will send Y flying. "with repetier manual control."
If I home all they thump X then Y then stick on Z waiting for me to press end stop. The X and Y home disapears before you get a chance to press end stops. but Z will hang.

Got Z moving with manual control like extruder but cant get Z to move woth LCD.

So I am getting movememt with repetier.
Only error I get is visual something turn it off in basic setting.

Ive gone and tried to tune my pots on my drivers which im seeing different effects. But nothing like a proper home. They should go to the end stop when I press home right?

Tronxy X1
Machine fw
Repetier 0.91 x1.2 v1.1
Machine board
Melzi 2.0 v5
XYZ tronxy 42H3454-23, E42H4054-16 I think E driver volts may differ to the rest hence E moving at 0.001v but tbh had them all turn at that but E driver gets hot.

I even installed all the old repetiers too. Ponterface, various driver fixs.

Is there no way I can tune from a print? or type in some gcode to tune my pots?

If any one has the same board could you please post or inbox me the pot volts on each driver.

Ive removed the reset jumper ect and tried like that, been setting volts with just usb but tbh I thought fk it and done it with full power jumper with reset jumper so repetier emergency stop will reset it as im seriously pushing my luck with these drivers and motors.

I cant get motor info and have tried and got a feeling steps per mm may have a part to play but other users are using exact same setting with no problems?

Ive followed alot of guides now. Greetechs was best as they had melzi2.0 v5 guide.

Please no stupid asz replies or replies that ask and dont answer anything. Its annoying.

Ive tried a bunch off eeproms, printer settings which I think may be a issue.

Ive tried to print and then turn the pots on the drivers to tune but cant even get E motor going.

I bought the drivers down from 0.780v to 0.001v and all the way back up with no real differences, set at 0.001 in video as the extruder will move with the lcd and so will Z except with repetier tbh I had X and Y move with Hi steps per mm

Is there a order or way to do the drivers while printing? Ive watched alot of tuning and believe my eeproms fine.

Could it be steps per mm?
Ive got exact settings that a bunch of other people are using tho?

I think im have to reflash this with something else as its a nightmare. Please advise a better solution as I really need to pront some bits for my other printers. I dont want to give up but its really exhausted me now so please tell me some solutions we can try.

Thanks in advance.
Tbh id be happy if the machine just worked off the SD card thats what I wanted.

If I can tune the pots to make motors work while printing from sd card or with slicer/cura printing please let me know as Im really sick of it now.


  • Your video is very hard to follow. All I saw was a extruder controlled manually just jittering from having no second coil powered or not enough power to turn. Are you sure motors are connected correctly? If you have normal speeds and steps per mm you should see smooth moves, which I do not see so that seems to be the root problem at first glance.

    There are 2 ways to connect the 4 motor cables but only one is correct and will work. Check driver documentation how to wire them correctly.
Sign In or Register to comment.