eeprom configuration greyed out

Hi, I upload repetier firmware including EEPROM_MODE 1  and M205 show me the values in the eeprom.
But the eeprom configuration could not be used. Why is that? I thought I could change after the upload of the firmware the values by this menue point. Or do I misunderstand this?
Hope somebody could help on this.


  • The eeprom menu gets enabled when a compatible firmware is detected. For this the host monitors the response on M115 and if it shows repetier firmware it gets enabled. Check your log what M115 returns and if eeprom is enabled after receiving this. Maybe you have changed the firmware string?
  • Thanks. I changed the firmware string back to repetier and now its works.

  • Hi, I have the above same problem-Da Vinci 2 Duo-upgraded FW to Repetier 0.92 - greyed out EEPROM in host. 

    Host keeps reporting that 'COM(port) does not exist' - I have tried settings from 1-11, host (seems to) connect (the connect button goes GREEN) but when i disconnect it throws an error saying the port does not exist.

    How (please) do I action M115 to check the firmware string?

  • Ok understand the host manual shell now

    But still have no comms between computer & printer?

  • No worries, binned it.
  • How do I select repetier firmware please. I have tried quite a few now to have a play with the settings and seem to be getting in a right pickle
  • In the host you do not select the firmware. Host detects it on connection cause it sends M115 to do so. All you could say is using repetier protocol but autodetect will switch anyway, once it sees a repetier-firmware.
Sign In or Register to comment.