Touchscreen and hostname


    I have Repetier Server Pro (Image V7 with Repetier-Server 0.85.1) on a Raspberry Pi 2 with a touchscreen (Waveshare 7’’ HDMI LCD (C) rev 2.1).

    Initially, everything is working perfectly, both image and touch function, but when I change the hostname (via raspi-config), and after reboot, the following message appears:

    If I choose “Quit” the screen goes to gray and remains until a reboot, which shows again the same message.

    If I choose “Unlock Profile and Relaunch”, the server’s screen shows correctly, but when I attempt to tap on any button, it starts to make strange things: zooming in/out, tap on a button and another activates instead …

    Sorry if the fix for this is obvious, but I do not know much of Linux.



  • For me "Unlock Profile and Relaunch" worked just as expected. All positions were recogniced afterwards, but that is with  the 7" official pi screen. That doe snot sound like it is coming from chrome - I would bet on the waveshare touch driver. Initially you have calibrated that I guess with xinput and adjusted a file. I think it does now not use that configuration any more. So try that calibration again according to the waveshare docs.

    If it is chrome you can delete the cache
    rm -r /home/pi/.cache/chromium
    sudo reboot

  •     Hi,

        I already tried calibrating the screen before opening the discussion, but that did not fix it.

        After I entered “rm -r /home/pi/.cache/chromium” and rebooted, the message box still showed but this time, after selecting “Unlock Profile and Relaunch” the touchscreen works correctly, so, it seems it is fixed.


Sign In or Register to comment.