[0.80.3] server keeps sending commands during M190/M109



  • WOO HOO!   Success.

    I commented the busy response line in marlin.xml as you suggested and everything worked as expected.  I ran the print job twice (letting everything cool down in between) and it waited on both the M190 and M109 commands.  Even when it issued busy responses later in the print, it didn't ever issue one of the timeout messages.

    Marlin seems to have the busy messages on by default.  Maybe in my first version of Marlin, they weren't putting it on which is why it worked before.

    Wow this was quite an ordeal, but I'm glad you figured it out.  I've missed being able to print directly from the UI.

    Thanks for hanging in there :)
  • Your results underline my theory. So when you make server not detect busy it just ignores them and works like with older Marlin versions where there was no busy at all (which is why it worked). So now server will not timeout for M109/M190 but will for some slow commands not listed. So you normally set timeout to 30 seconds to catch these without timeout or live with them and get a resend to fix when firmware is finished. This happens especially on G1 moves that take longer from being long os low. You can also enable in marlin "wait" which will fix real timeouts very quickly since a wait means buffer is empty.
Sign In or Register to comment.