Failed installation on OrangePi PC

Hi all,
I have tried to install repetier server on my OrangePi PC, running the rasperian linux. After downloading the newest version I tried to install it with the following command: sudo dpkg -i Repetier-Server-0.80.3-Linux.deb. But after a while I get the following error:
[....] Starting Repetier-Server: rsdKilled
dpkg: Fehler beim Bearbeiten von repetier-server (--install):
  Subprocess installed post-installation script returned the error 137
Errors occurred while editing:

What is going wrong here?


  • Raspian on pi is one of the most tested combinations, so I wonder it is not working.
    Does /var/lib/syslog contain more informations on what failed? The postinstall script sets up the user and start script. Since one part failed something might not be set up correctly.

    You can try starting manually
    sudo RepetierServer start
    and check the error you get. /var/lib/RepetierServer/log/server.log might also contain more infos.
  • Hello,
    /var/lib/syslog is not available. Also  /var/lib/RepetierServer/log/ is empty. So no further information here...

    root@orangepi:~# dpkg -i Repetier-Server-0.80.3-Linux.deb
    Vormals nicht ausgewähltes Paket repetier-server wird gewählt.
    (Lese Datenbank ... 78036 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacken von repetier-server (aus Repetier-Server-0.80.3-Linux.deb) ...
    repetier-server (0.80.3) wird eingerichtet ...
    Install Repetier-Server
    You may see warnings about groups. These can be ignored.
    Füge Benutzer »repetierserver« der Gruppe »tty« hinzu ...
    Benutzer repetierserver wird zur Gruppe tty hinzugefügt.
    adduser: Die Gruppe »intserial« existiert nicht.
    adduser: Die Gruppe »ugpio« existiert nicht.
    [....] Starting Repetier-Server: rsdKilled
    dpkg: Fehler beim Bearbeiten von repetier-server (--install):
     Unterprozess installiertes post-installation-Skript gab den Fehlerwert 137 zurück
    Fehler traten auf beim Bearbeiten von:
    root@orangepi:/var/lib/Repetier-Server# ls

  • Installation succeeded completely I think as starting server is last command. Try starting from commandline to see what exactly happens
    sudo -l repetierserver /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml

    should also start it and show some messages on terminal since your prblem is before loggin is enabled. If that does not show enough try
    sudo -l repetierserver strace /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml
    whcih logs also all file access. My guess is that something is not setup as normally so it fails at some point. Some systems have for example no sudo installed whcih is required.
  • One additional question befor I test you commands: Which Linux version do I have to download? I used the armel version. Is that the correct one? I saw in a youtube tutorial that he used the armhf version!?
  • armel is for pi 1 but also works on arm versions with hardware floating point. Most arm boards have a armhf capable chips and I guess the orangepi as well. 
  • When I type /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml the server starts and I have access from my laptop, which is great. But the server doesn start automaticaly after a reboot of the orangepi. How can I do to solve this?
    One problem I have is that I can only login with the root user. When I user the user orangepi I can type my password but I come back to the login again. The user orangepi is available and has a valid password, but login doesn't work. Thats the reason why I work with the root user. So when i use sudo -l repetierserver ... I get an error "sudo: list: command not found".

    Here is what I get in the /var/lib/RepetierServer/log/server.log:

    2017-06-20 16:23:27: Start logging...
    2017-06-20 16:23:27: Webdirectory: /usr/local/Repetier-Server/www/
    2017-06-20 16:23:27: Storage directory: /var/lib/Repetier-Server/
    2017-06-20 16:23:27: Configuration file: /usr/local/Repetier-Server/etc/Repetie$
    2017-06-20 16:23:27: Directory for temporary files: /tmp/
    2017-06-20 16:23:27: Reading firmware data ...
    2017-06-20 16:23:27: Starting Network ...
    2017-06-20 16:23:27: Active features:0
    2017-06-20 16:23:27: Reading printer configurations ...
    2017-06-20 16:23:27: Starting printer threads ...
    2017-06-20 16:23:27: Starting work dispatcher subsystem ...
    2017-06-20 16:23:27: WorkDispatcher table created successfully
    2017-06-20 16:23:27: Starting user database ...
    2017-06-20 16:23:28: Initalizing LUA ...
    2017-06-20 16:23:28: Register LUA cloud services
    2017-06-20 16:23:28: add Repetier-Renderer
    2017-06-20 16:23:28: LUA initalization finished.
    2017-06-20 16:23:28: Starting web server ...
    2017-06-20 16:23:28: Work dispatcher thread started.

  • Ok, so it now becomes clear what the problem is. You are not running raspian but a debian version with no sudo installed, which is required. Therefore installation failed. Install sudo package as root
    apt-get install sudo
    and reinstall software. I think then installation runs through. Server normally runs under repetierserver user, check /etc/passwd if it contains that user. Maybe that also failed.

  • Hi,
    sudo is already installed:
    "root@orangepi:~# apt-get install sudo
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    sudo ist schon die neueste Version (sudo is the newest version).
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 23 nicht aktualisiert.
    1 nicht vollständig installiert oder entfernt."
    So missing sudo doesn't seem to be the problem.

    In /etc/passwd there is the following entry:

  • My sudo command was wrong. Should be
    sudo -u repetierserver /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml
    so with -u insetad -l
    Since you already started it as root the files belong to root should
    chown -R /var/lib/Repetier-Server
    before. Maybe that gives a hint. Since it works for root it must be something permission related, also everything seems to be configured correctly.
  • Sorry, but all that doesn't help. As I am logged in as root the chown doesn't change anything. All files in /var/lib/Repetier-Server belor to user root:root.
    I guess that the problem is, that I cant't use another user on my system. See the following sequence:

    adduser orangepi
    adduser: Der Benutzer »orangepi« existiert bereits. (User allready exists)
    root@orangepi:~# su orangepi
    root@orangepi:~# login orangepi
    Letzte Anmeldung: Dienstag, den 20. Juni 2017, 22:50:19 CEST von auf pts/1
    Linux orangepi 3.4.39 #41 SMP PREEMPT Sun Jun 21 13:09:26 HKT 2015 armv7l

    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.

    When I want to shitch or login to the user orangepi I still stay as root user. But I have no glue how to change this. I also found nothing on the net...

    If nothing helps I put a start command in the file /etc/rc-local for an autostart. That works a workaround.
  • Ok, lets assume you can not switch user (whcih you should be able as I never saw a linux not doing it). YOu can set the startup code to run as root.
     nano /lib/systemd/system/RepetierServer.service
    Then edit the
    to root and also adjust the chown commmand and reboot. Should then simply run as root. Only after updates you might have to redo this.
  • Ok. Thank you for your kind support.
    Best regards
Sign In or Register to comment.