update of prusa edition


Is there a guide to how i can update the build in prusa edition of slic3r? just so i can keep up to date. Latest version is 1.35.5


  • edited June 2017
    i tried to unzip the latest version in a new folder under repetier host folder and point to that from within repetier host

    but i get this long error list: https://pastebin.com/PC1CWihY

    and slic3r does not open
  • also when i open this manual (ie not through repetier host) its a lot unresponsive to the point where its useless

    is that why it has not been updated yet?

    i tried to use the latest settings from prusa but these give me this much shorter error list:

  • They update quite often so we can not follow every update. When we update we will include the latest version of course.

    The trick is to point to the console version and not the gui version and select the "Slic3r Prusa Edition" slicer to it not the "Slic3r" version, since prusa needs different handling.
  • ahh.... that makes sense, i pointed to the gui version.. will fix that

    i tried to enable variable layer height and i got this error:

    15:25:58.109 : <Slic3r> Caught C++ exception of type or derived from 'std::exception': vector<T> too long at C:/PROGRA~1/REPETI~1/Slic3rPE/lib/Slic3r/Print/Object.pm line 197.
    15:25:58.242 : <Slic3r> Slic3r installed in a loclized path. Using an 8.3 path: "C:\PROGRA~1\REPETI~1\Slic3rPE\"

    any clue that what that could be?
  • btw i uninstalled the normal slic3r version so its not messing things up

    i extracted the latest from prusa in a new folder and pointed to: C:\Program Files\Repetier-Host\Slic3r_New\slic3r-console.exe

    still it will not run, will try and see if i did anything wrong

    when i launch the gui version directly i can get it to run with all settings etc availble, but its just so slow :-D

  • i have given up on updating to the latest version

    but i would still like to use variable height
  • With bundeled version it worked great. Soon I update host and will include new slic3r PE so then I will see if they have changed something making it incompatible. After all it is a quite new feature so changes may happen.
  • i do use the bundeled version :-D

    updating was to much trouble for me
  • aah, I see what the problem is, "--gui-mode simple/expert" has been removed.
    This is according to the changelog on the web site.

    The following features were removed:

       The "simple" mode has been removed as it was too simplistic, therefore nobody used it.
    The "--gui" option is still there, but if you call it with "--gui-mode <simple/expert>" it just gives the calling instructions.

    I would suggest you remove the "--gui-mode" part or tell us where you add the "--gui-mode" part and we can remove it ourselves?
  • It is inside the dll compiled in, so nothing you can change. But since we include that version in near future I will fix that switch for upcoming versions. Thats the classic problem if commandlines change.
  • I know you probably get asked this often, but when do you expect to have a new version, with this change available?

  • In july we plan an update.
  • The new version of Slic3r Prusa Edition 1.36.0 fixes the Repetier issue:
    • Fixed a Repetier Host compatibility, broken in 1.35.5 by removing the --gui-mode option. This option has been reverted for compatiblity reasons, though the option is inactive. #363
  • Have already added --gui for 1.35.5 :-)
  • Repetier said:
    Have already added --gu i for 1.35.5 :-)
    Looking so forward to this!
    Is it possible this option to be part of the slicer manager as a slicer launch parameters field?
  • In theory yes, but that is likely to cause collisions and errors with all the params we already add to the call. I do not think they will change that so frequently so we need that.
Sign In or Register to comment.