Server won't start on windows 10 after working fine.

edited June 2017 in General
For whatever reason, Repetier Server service refuse to start. It has been working fine for days before.

here is the error in Windows events log:

Nom de l’application défaillante RepetierServer.exe, version :, horodatage : 0x5849222c
Nom du module défaillant : RepetierServer.exe, version :, horodatage : 0x5849222c
Code d’exception : 0xc0000005
Décalage d’erreur : 0x00035e20
ID du processus défaillant : 0x9b4
Heure de début de l’application défaillante : 0x01d2db936b816378
Chemin d’accès de l’application défaillante : C:\Program Files\Repetier-Server\bin\RepetierServer.exe
Chemin d’accès du module défaillant: C:\Program Files\Repetier-Server\bin\RepetierServer.exe
ID de rapport : af2fbb3c-bb91-470f-8c40-e7a0dc948e56
Nom complet du package défaillant : 
ID de l’application relative au package défaillant : 

Sorry it's in French, but error numbers are easy to translate.... :-)
I tried rebooting, re-installing, same. No ideas what to do next!

Thanks for your help,

Sorry, forgot to say: as the version is not displayed, I should have said it's with the last one:  0.80.3


  • All data and databases are stored inside C:\ProgramData\Repetier-Server and since it worked before, I assume a file is corrupted causing the crash. So what you first should do is stop server, rename folder and start server. Now I assume it will work as before.

    If it now works, I would really like to know which corruption the problem causes. So you could stop server and add parts of the renamed folder to the new created folder and restart to test. I would start by adding database directory bag, so you have your old license data etc back after the restart.

    Next turn configs and then the printer folder parts.

    At some point it will not start any more and then you know one of the files added causes the crash. 

    If you look int the log/server.log file you might maybe reduce the search as server logs it's steps and seeing how far it comes might also narrow the problem. In any case should renaming and restarting folder make it work again.
  • In between, I installed the previous version, hoping it would work, but it's the same. So I will re-install 0.80.3, and start doing what you suggest. I already made a backup of that directory, so I guess I could just remove it, and re-add old files from my backup, one after the other.

  • It works after re-installing 0.80.3. So now I am starting to add parts, will let you know how it goes.

  • OK, I uploaded my printer XML file, after having copied the "printer" folder entirely, and it works, with all my models already in the server, so now I am going to try if everything is OK between Host, server, and printer. I'll add other parts later, slowly. Now that it works, I am a bit reluctant to break everything again....

    Thanks for your help, and a great suit of softwares...

  • Well, I just printed ONE model, and the server stopped after it was done! Can't restart.

  • Removed all models from the folder, it restarted; Does it update the database from there? I'll continue to update you on what is happening, as I really want it to be reliable.

  • The server stopped after ONE print! I am going to send you the GCode of that print, no idea if it is linked or not.

  • Here is the last part on the server.log; if it can help you to see what's going on...

    2017-06-02 17:06:26: LUA job rendering.render#{"id":1,"image":"C:\\ProgramData\\Repetier-Server\\printer\\Anet_A8_Orange\\jobs/00000001_Centering_Target_v2_l.png","layer":"C:\\ProgramData\\Repetier-Server\\printer\\Anet_A8_Orange\\jobs/00000001_Centering_Target_v2.layer","list":"jobs","slug":"Anet_A8_Orange"}
    2017-06-02 17:06:30: error taking snapshot:Timeout
    2017-06-02 17:06:34: Reading configuration file ...
    Build 2
    Input file: C:\ProgramData\Repetier-Server\printer\Anet_A8_Orange\jobs/00000001_Centering_Target_v2.layer
    Rendering shadows ...0.200499 seconds.
    Rendering gcode ...1.5405 seconds.
    Number of end triangles: 1656
    Number of normal triangles: 37468
    Rendering background ...
    Time for raytracing: 5.023 seconds.
    Computation time: 7.6705 seconds

    2017-06-02 17:07:00: error taking snapshot:Timeout
    2017-06-02 17:07:30: error taking snapshot:Timeout
    2017-06-02 17:08:00: error taking snapshot:Timeout
    2017-06-02 17:08:30: error taking snapshot:Timeout
    2017-06-02 17:09:00: error taking snapshot:Timeout
    2017-06-02 17:09:30: error taking snapshot:Timeout
    2017-06-02 17:10:00: error taking snapshot:Timeout
    2017-06-02 17:10:30: error taking snapshot:Timeout
    2017-06-02 17:11:00: error taking snapshot:Timeout
    2017-06-02 17:11:30: error taking snapshot:Timeout
    2017-06-02 17:12:00: error taking snapshot:Timeout
    2017-06-02 17:12:30: error taking snapshot:Timeout
    2017-06-02 17:13:00: error taking snapshot:Timeout
    2017-06-02 17:13:19: Print of Centering_Target_v2 on printer Anet A8 Orange finished. Send 3133 lines. Printing time: 0:06:54

  • Log only shows that you wanted to make a timelapse but webcam was not reachable. Everything else there was ok.

    Important: Always stop server before adding/changing files manually. Otherwise it might get confused or write old data etc.

    On restart all databases not present get replaced by new ones, but of course empty.

    Here from server.log what it looks like on a normal startup:Read configuration file

    Testing alternative config: "/Users/littwin/Documents/Projekte/Repetier-Server/Repetier-Server/repetier-server-extra.xml"
    Testing alternative config: "/Users/littwin/Documents/Projekte/Repetier-Server/storage/database/RepetierServer.xml"
    Imported external command Gnuplot
    Imported external command Slic3r
    Imported external command Test
    Imported allowed execute command play
    Webdirectory: /Users/littwin/Documents/Projekte/Repetier-Server/Repetier-Server/www/
    Storage directory: /Users/littwin/Documents/Projekte/Repetier-Server/storage/
    Configuration file: /Users/littwin/Documents/Projekte/Repetier-Server/Repetier-Server/repetier-server.xml
    Directory for temporary files: /var/folders/lq/hp16fyy976qf55g63v1xfsg40000gn/T/
    Reading firmware data ...
    Starting Network ...
    Active features:4095
    Reading printer configurations ...
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Davinci.xml
    Starting printjob manager thread for Davinci
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/DeltaTest.xml
    Starting printjob manager thread for DeltaTest
    Register LUA cloud services
    add Repetier-Renderer
    LUA initalization finished.
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Felix.xml
    Starting printjob manager thread for Felix
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Geetech.xml
    Starting printjob manager thread for Geetech
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Marlin_RAMPS.xml
    Starting printjob manager thread for Marlin_RAMPS
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/P3.xml
    Starting printjob manager thread for P3
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Printrboard.xml
    Starting printjob manager thread for Printrboard
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Test.xml
    Starting printjob manager thread for Test
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Testprinter.xml
    Starting printjob manager thread for Testprinter
    Reading printer config /Users/littwin/Documents/Projekte/Repetier-Server/storage/configs/Testprinter_2.xml
    Starting printjob manager thread for Testprinter_2
    Starting printer threads ...
    Starting printer thread for Davinci
    Starting printer thread for DeltaTest
    Starting printer thread for Felix
    Starting printer thread for Geetech
    Starting printer thread for Marlin_RAMPS
    Starting printer thread for P3
    Starting printer thread for Printrboard
    Starting printer thread for Test
    Starting printer thread for Testprinter
    Starting printer thread for Testprinter_2
    Starting work dispatcher subsystem ...
    Starting user database ...
    Initalizing LUA ...
    Starting web server ... 
    Work dispatcher thread started.
    Webserver started.

    For you of course with different printers. But from the progress there I could see how far it goes and if it happens while loading the database or scanning the printer folders for gcodes present. Especiall in models/jobs folde rof printer a defect .gin file was able to cause troubles. Next release will autofix defect .gin files. You could delete them before starting as they would get rebuild on startup then.
Sign In or Register to comment.