Dual Extrudor Not Working Properly

I am having problems with my extruders not swapping when printing something that requires two materials.  I am using Sli3er.  Here is some info on how I am setting up everything:

1 - I am importing 2 STL files made in Solidworks and then I combine them by dragging them together and assigning each the appropriate extruder.
2 - I have my printer settings set at "2" extruders in Sli3er.
3 - Under print settings, multiple extruders in Sli3er I have extruder 1 set for perimeter extruder and extruder 2 set for infill extruder.
3 - I have the same print setting selected in Repetier as the above settings in Sli3er.  
4 - In Object Placement in Repetier each object is assigned its appropriate extruder.  

This is my "Slicer" tab view in Repetier.  I am not sure if I am missing any options.  I have read a few places that have an option to pick dual head or single head mode.  I am using an Inkredible plus Bioprinter and have it selected.

Any assistance would be appreciated.


  • The version of Repetier I am using is V2.0.1 and the version of Sli3er I am using is 1.2.9.
  • Nice tutorial so far, but is the part going wrong? I'm not sure about infill extruder as we assign each stl an extruder that might get ignored in favour of selected extruder for object in host. The settings in slic3r are for not assigned parts.
  • Thanks for the reply.  I assigned each stl and extruder in Repetier, but both parts (blue and yellow in picture) are being printed with extruder 1.  I cannot get extruder two to do any of the printing.  Are you saying that I should change the settings in Sli3er so that I am not using extruder 2?
  • Just tested and worked for me. In my Slic3r Multi-extruder settings I have infill and perimeter set to 1. Not sure if that changes anything. 2 extruders in printer selected defined.
  • Ok.  Thank you again for the assistance.  When I get back to my lab I will try that and see if it works.  
Sign In or Register to comment.