Where is the Z axis feed rate defined?

So I have seen this brought up several times in the forums usually as the first layer being too high. I found out that the reason, at least my reason, is that when the gcode for layer changes is generated the feed rates are at 7800. In my case it is too high and my z steppers just skip all those steps. I cannot find anywhere in my firmware or the Repetier config where this is specified to change it.

However If I manually edit the gcode and replace the 7800 with 200 the gcode works fine. Anyone have any ideas on this?  Thanks!


  • OK never mind. I was able to answer that question. The answer is that the value is calculated from the Slic3r Prusa Edition configuration settings, specifically the Speed - Speed for non-print moves: Travel. By default it is set to 130 mm/second. In the G-Code, the feed rates are represented in mm/minute. 130mm/s x 60 = 7800mm/minute.
  • Yes, they have no special speed for Z. This means they rely on proper firmware configuration where you can limit z speed. So reduce max. z speed in firmware to what is possible and you will never again have any problems with z speed.
Sign In or Register to comment.