nearly there just having problems with temp control

all the movements are now fine and the extruders work good as well 
its just the heating on everything
the thermistors and hot ends are e3d chimera's and I have been told by e3d to use the ATC semitec as this should work. I have changed the thermistors as I thought they may be faulty but they are still giving the same results.

my temp starts off on -20 degrees but once I manually heat up the thermistors I can heat them up and the temp will rise on the LCD and repeiter host.
but once they get to about 160 it slows down and find it hard to get above 170

Also, the bed always shows 33 degrees but I can heat it up manually.
with the bed, i have tried every option for thermistors and thermistor pin from analogue 1 to analogue 15. and none really work.

My printer is a hictop Persia i3 with a mpx.3 board installed its a 24 volt system and i have tested all thermistor pin sockets and i do get a voltage coming from the board i just can't get the bed to change the value from 33 degrees. and i cant get a true temnmp reading on the hot end thermistors

i have tried the dev version of the firmware and the main version none seem to work even the dev version with the board listed


  • found out why i cant heat up my hot end.. it was too close to my heat sink
Sign In or Register to comment.