No EEPROM reading on Host V. 2.0

Hi, I tried new version of Host on my Linux mint system but i can't read eeprom. On mega2560+ramps "Firmware eeprom configuration" in Config menù is not enabled. On arduino due+smart ramps instead menù is enabled, after click it open eeprom window, but is empty.
I tested 3 printer with same result. on v. 1.6.2 is everithings ok.


  • Hello!
    I have the same problem. I am going back to 1.6.
    They should check the SW before releasing it on all platforms. That means Linux also.
    Besides, the new layout is a catastrophe. No visibility at all.

  • What firmware are you using?
    What is the M115 response string? Firmware needs to detect firmware version to select the right editor until then it stays grey and some vendors modify the strings to unknown values.
  • edited April 2017
    Yours. Dev version.

    M115 response in arduino mega...

    in arduino due...with also DEV version

    It's enough i think.


    The eeprom window on arduino due, is not with empty fields, it is without text fields, is totally gray.

  • Cap:EEPROM:0

    tells host that no eeprom is supported. That was for a time wrong in dev so that may be the problem since it overrides firmware detection. Will check linux eeprom, not sure if I only tested this on windows as it should be compatible but as you might know mono sometimes has it's own definition of compatible.
  • Just for test, i reprogrammed mega+ramps with dev version (fresh download), now M115 command show cap:eeprom:1 and menu item is enablad, but is exactly the same of arduino due...window gray with no text fileds
    like this...
  • Ok, I can reproduce it under linux. Wondering what is going on here since I only changed the colors and no functionality and same code under windows is working. Will see what I can do.
  • Ok, Thanks. I'll wait with confidence.
  • So I have Windows 10, can confirm that when I updated to Version 2.0, that the eeprom was greyed out. m115 returned eeprom : 1, so it was enabled, however still not able to access it.

    What I did is went to the configuration tool online, load my old configuration.h file so it has everything that my printer currently has, and redownloaded it, re uploaded and the eeprom option is no longer greyed out.

    Problem is, it looks like my eeprom was still intact, but I cannot confirm because I didn't think about losing my eeprom settings previously. Oh well, it was time to calibrate from scratch again anyway....
  • No eeprom was intact. It was just a error in reporting eeprom availability. The eeprom function itself was not affected but since host now news the more correct answer it did trust it and since it was wrong it was greyed out.
  • edited May 2017
    Is this listed as a bug now?
  • It was a firmware bug that has been solved.
  • Hello
    Have the same problem
    Marlin 1.1.9
  • Is Marlin compiled with eeprom support?
    What does it report in Cap:EEPROM at startup/M115?
Sign In or Register to comment.