"Freezing" at startup

Has anyone else experienced an issue with it "freezing" at startup?  The splash screen appears and does not go away, a window opens but it's blank (never painted even once, it just displays my desktop), and mono sits spinning at 100% CPU.  That's why "freezing" in quotes, because it's still doing something... I just don't know what. Busy loop for something.
It didn't used to do this, used to work fine.  This happens with the latest mono and repetierHost (4.8.0 and 1.6.2 respectively) but I also have an older build which I had had to hack together to make work from a couple years ago (mono 3.99 and repetierHost 1.0.6) which, again, used to work perfectly but now exhibits the same problem.
I've obviously updated something that has completely broken either repetier or mono, but I can't tell what.  If the version of mono and repetier are the same, what else should I be investigating?
I'm running arch linux, 64bit, 4.10.9-1 kernel.


  • First start host from a terminal so you see output errors.

    Then you could start it using strace before which outputs lots of things it does like openening files etc. Maybe this gives an indication wat it tries when hang occurs.

    One typical candidate is always OpenGL. But normally you see the rest of the window so it might a well be anything else. Newer linux versions do not install winforms any more by default. User
    sudo apt-get install libmono-system-serviceprocess4.0-cil libmono-winforms2.0-cil
    to add that library.
  • Hello,
    thank you for your response but there are no errors. It does not crash, it just spins at 100%, never displaying anything.  There are a bunch of "libpng warning"s, but they've always been there, and many other people have had them forever as well; it's just a warning that is supposed to be safe to ignore, which is good because I can't get rid of it.
    Winforms is part of the mono package in arch linux, no need to install separate libraries.
    Anything else I might be able to try?

    uh... ok, so running it with strace works.  Running "mono RepetierHost.exe" it does this CPU spinning thing and gets nowhere, running "strace mono RepetierHost.exe" everything starts as normal.  What the what?
  • That is strange. strace is no helper to get anything running. It just logs actions done by software. All it does is changing timings maybe as it slows down by logging a bit. Very strange.
  • Ok, I've run it a few times now to try and get different results. One time it actually froze my entire PC (probably an openGL issue) and I had to restart.  But when it came back and I tried again I actually got the "freezing" issue this time.  So bizarre, no idea why it sometimes works and sometimes not.
    Maybe this will help make sense of things: http://rebirthofxeen.com/repetierHost_strace_trimmed.log
  • Correction: now it's not working at all, either way. Always does the same thing. Something different since my computer restarted.
  • No, can not say why it is waiting for a pid forever. At startup it does not start external threads. For next release I will test with recent ubuntu and see if that has similar problems.
  • I ran into the same issue. When doing an strace of repetierHost it sometimes starts the program (maybe once every 8 times). When inspecting the strace logs when the program fails to start I am also seeing a lot of getpid() followed by and endlessly repeating sched_yield().

    I am running:
    Fedora25: kernel 4.10.15-200.fc25.x86_64
    Mono: Stable
    NVidia: binary driver 378.13 (patched for 4.10 kernels)
    Mem: 16G (free 11G)

    I can test the new release when it becomes available
Sign In or Register to comment.