Possible mains interference problems?

I've had a couple failed prints over the past week or so that were a result of the printer losing serial communication with the server mid-print. I'm suspecting that this is a result of noise on the AC mains line, though I suppose I can't be sure. The reason I suspect this is that in both cases it happened as I was walking away from my workbench. The first time I turned off a CFL desk lamp and the printer immediately rebooted. The second time I turned off my Hakko soldering station, causing the printer to reboot. The frustrating thing is that while these devices are all plugged into the same wall outlet, the Repetier-server PC (Intel Atom D2700 running Debian) and the printer are powered by their own dedicated power-conditioning UPS. I was specifically trying to condition the power and avoid issues like this.

Anyway, in trying to resolve this issue, I have a couple questions:
1. Currently I'm running the printer at 115200 baud. I'm using the repetier protocol, so given the compression of the binary protocol as compared to ASCII, I was wondering if 57600 baud would be fast enough. Lower baud might make me less susceptible to comms issues.
2. Is there any possibility of bypassing the FTDI chip and interfacing directly over hardware serial to a Melzi board? My repetier-server host PC actually has a couple hardware serial ports.

Some details:
My printer is a Wanhao i3 v2.1. I've upgraded the firmware to Repetier 1.0.0dev, I'm using Repetier-Server v0.80.3. When I had the control box open in order to install the heatbed MOSFET mod, I also removed J14, the auto-reset on serial connect jumper.

Aside from my two questions above, do you have any advice for me regarding how I can avoid losing serial comms mid-way through a print?




  • Some houses/regions are really that unstable that a lamp or something can cause the device to malfunction. In that case a lower baud rate is not a solution. It is not a comm error causing the reset. It is the usb restarting that is your problem and that might happen because the printer resets when you turn light off. Have you tried if a not connected printer would also reset when you do that? Should be visible on printer lcd if that happens. 

    Solution is normally to put a battery powered UVP before that device getting problems.
  • Well that's frustrating. I thought the UPS that I'd purchased had voltage regulation, but it turns our after double-checking that it doesn't. I'll have to go find another one.

    Regarding the reset, I was watching the LCD on the printer the second time (when I turned off the soldering station) and the printer did not reboot, which is why I thought it was a comms issue. You're right that the LCD makes the boot process very obvious (Boot logo, repetier version number displayed, etc). The first time I had the problem it did reboot, but I still have J14 connected meaning that if the problem WAS a comms issue then the repetier-server reconnecting would have caused the reboot, not necessarily an A/C mains problem.

    Anyway, I'm going to find a UPS that supports AVR and see if I experience the problem again. I'll report back if I have any further problems.

    Thanks for your advice.
  • You could use also something like APC Back-UPS ES 400 where you can plug in several devices at once like printer, pi and pc. Since the shock is short it must not last long, just correct immediately.
  • Just a quick update on my problem:

    I wound up trying both a TrippLite Smart1000RM1U UPS, as well as an APC BackUPS Pro 700. Both of these UPSs have AVR, and neither of them solved the problem. I could still trigger a loss of communication between the repetier-server and the printer at will simply by turning off/on the soldering station or LED lamp. The printer and the repetier-server host PC are the only devices connected to the AC-out of the UPS. Everything else is connected directly to the wall.

    In the end, I solved the problem by connecting the AC-In of the UPS into an old X10 plug-in filter module (XPFF) I had laying around, and then plugging that into the wall.

    Now I can flick anything I like on/off as much as I like without causing problems. So it seems like this was caused by interference on the mains as I had originally suspected. I have a fair bit of experience with sources of AC interference from back when I used to use X10 extensively. I'm just thankful I've moved everything to Z-Wave Plus these days ;)

    Thanks for your assistance,

  • Ok, having no electronic background I do now know what X10 is, but be glad you found a solution to stop the interference.
Sign In or Register to comment.