Repetier Server on Rasperry: printing idle when activate or deactivate the "Access Point" feature

edited March 2017 in Bug Reports
I've my Raspberry PI 3 connected via wifi with a dedicated external wifi dongle, and i've enabled the "internal Access Point feature" if the external wifi go down.
Analyzing the server log I noticed that unfortunately due an unstable wifi link the internal "Access Point" feature is often activated, and when it happens the server stops sending data to the printer for a few seconds, even then it continues printing.
noticed this "bug" because obviously the nozzle creates a random dot in my printed object.
When disabling this feature I've not had this problem, now the internal "Access Point" feature is always off and all work fine, without pause.
So Roland please check if there's something wrong when the Access Point go up or down, probably it freezes for an instant the communication on the USB port.


  • edited March 2017
    And I don't understand why every 12 seconds this thing is repeated in the log, ever.
    Server version: 0.80.3 Pro.

    2017-03-25 20:37:04: Activating access point
    2017-03-25 20:37:41: Activating access point
    2017-03-25 20:38:18: Activating access point
    2017-03-25 20:38:58: Activating access point
    2017-03-25 20:39:34: Activating access point
    2017-03-25 20:40:11: Activating access point
    2017-03-25 20:40:48: Activating access point
    2017-03-25 20:41:25: Activating access point
    2017-03-25 20:41:46: Disable access point
    2017-03-25 20:41:57: Disable access point
    2017-03-25 20:42:09: Disable access point
    2017-03-25 20:42:20: Disable access point
    2017-03-25 20:42:32: Disable access point
    2017-03-25 20:42:44: Disable access point
    2017-03-25 20:42:55: Disable access point
    2017-03-25 20:43:07: Disable access point
    2017-03-25 20:43:18: Disable access point
    2017-03-25 20:43:30: Disable access point
    2017-03-25 20:43:42: Disable access point
    2017-03-25 20:43:53: Disable access point
    2017-03-25 20:44:05: Disable access point
    2017-03-25 20:44:16: Disable access point
    2017-03-25 20:44:28: Disable access point
  • edited March 2017
    I tried OctoPrint and haven't issue during printing, so it's not the fault of the Raspberry, cables or the printer board, is a software problem.
  • Changing wifi connection is in deed sometimes a problem. The complete linux system can freeze when network changes. This is nothing the server can solve a sit comes from network handling. But I see it activates or disables several times in a row which is not that helpfull so there should be some room for improvements. Next release will at least get a updated manager that hopefully does it's job much better, meaning less tests and switches. You might disable the wifi control form server by renaming cd /usr/local/Repetier-Setup/bin/manageWifiAccess to something else and restart, but then it will also not go to access point mode or you have to write something doing this.
  • Simply disable the access point from menu here solve the problem.
    Next release..... when? :-)
  • Problem not solved here, is not related to the wifi access point, damn!
    Tried other print object from SD and with Octoprint, no issue.
    When you think to release a new version of the server, also in SD image format?
  • Yes it will be a new sd image since we want to rework the wifi handling a bit based on problems some users seem to have.
Sign In or Register to comment.