Repetier Server crashes PC hard if the printer settings are updated while printing.

Not sure if this is a bug, or just me being incredibly stupid, but I made changes to the TRONXY printer's jerk and XY acceleration settings, while it was still printing. 

The moment I hit the "Save Configuration" button, RepetierServer.exe started grabbing resources. CPU usage went to 40-45 percent (8-core AMD FX-8320E CPU), drive usage went to 8MB/sec, and memory usage (24GB DDR3) went to 40 percent. The PC wasn't yet crippled, so I tried reverting the settings. 

Hitting the same button again caused RepetierServer.exe to use 92-95% CPU, 95% RAM, and 100% of HDD capacity. And that print? It's happening in a rather jerky fashion. NOW I'm crippled, right?

Okay, so two things resulted from the hard reboot I did after that. First, the system went back to normal. Settings were the ones I reverted to, and all model files saved to the server are gone. Roughly 13 pages of files, just gone.

Question: how do I get those print files back, or am I stuck re-slicing the STLs?


  • edited March 2017
    Update: the files are all still there, but something is preventing the server frontend from displaying them.

    I tried saving a new print to the server, and it threw an error: "Failed to remove model file"

    I can still print directly from RepetierHost, but the server frontend is now useless. Is there some database file I can delete, so that it rebuilds? I'd really like to use the server frontend system again.
  • Ok, here is what was happening.

    1. You seem to have several g-codes stored for upcoming prints.
    2. Changing timing relevant values triggers an update to all g-codes so print times get recomputed. So this is where you did go to 45%.
    3. Changing them back added another round of updates.
    4. Your reboot happened when one file was not written completely and reading it back crashes the import files so it shows no files any more.

    As solution please make sure you are on 0.80.3 before continuing. This will assure that updates are done file by file and not all files the same time. Next version will even have a test for such read errors so it should then not happen any more. Anyway after upgrading go to the storage directory where all your gcodes live. Delete all .linfo files or at least all with length 0. Then restart server. This will trigger an update of these files so they will appear after a while when all are computed.
  • edited March 2017
    This fixed everything. I killed all .linfo files, restarted the server, restarted the front end, and all my print files were right there. brilliant bastard. Sending money. Confirmation # 3XF78398XC822894W.

    Will upgrade to Pro soon. You have my gratitude.
Sign In or Register to comment.