WLAN connection problems and how to disable display.

Recently purchased a pro license as Iv been using the free one for a while and really like it.

Decided to go for a fresh install on rpi3, and now I'm having WLAN problems. Can get it to connect, but it randomly disconnects and switches back to AP mode.

Im looking in manageWifiAccess file to prevent the password loss issue, but the section refered to on the install page isn't there. This is what i see.


DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
cd $DIR

. ../etc/server.conf
export LC_ALL=C

function delSSID {
  foo="$(cat "$PWCONF" | awk '/'$P1'/ { flag=1 }; flag==0 { print $0 }; /network={/ { flag=0 }$
  if echo -e "$foo" | tail -1 | grep -q 'network={'; then
     foo=$(echo -e "$foo" | head -n -1)
  echo -e "$foo" > "$PWCONF"

function setHostname {
 foo=`cat "/etc/hosts" | awk ' /SERVERNAME/ { gsub(/^.*$/, " '$NEWNAME' # SERVERNAME"$
 echo -e "$foo" > /etc/hosts
 echo -e "$NEWNAME" > /etc/hostname
 hostname $NEWNAME
 service avahi-daemon restart
# Detect in which mode wlan is working
# Returns:
# Master = works as access point
# Managed = normal wlan access
# Unconnected = no wlan connected yet
# NoWLAN = no wlan device present

function getWlanMode {
  haswlan=`ifconfig | grep $WLAN`
  if [ "$haswlan" == "" ] ; then
    foo=`iwconfig $WLAN`
    wlanmode=`echo -e "$foo" | awk '/Mode:/ {gsub("Mode:","",$1);print $1}'`
    test2=`echo -e "$foo" | awk '/Mode:/ {print $4}'`
    test=$(echo -e "$foo" | awk "/$WLAN/ {print \$2}")
    if [ "$test2" == "Mode:Master" ] ; then

I also want to disable the display as i don't use on, and i again cant find the sections referred to in on the install page.

Whats going on? Are the instructions out of date?


  • No instructions are accurate. You just need to go further down the file to line 155. What you show is only the beginning of the file.
  • Arrr, thats been frustrating me for days!
    I assumed it would just show the whole file and I just needed to scroll down.
    Thanks for your help.

  • So Iv changed the files mentioned above, and I came home from work today to find the server has disconnected from the WIFI again and is back in AP mode.

    Any suggestions?

    Router is up and running fine and fixed on channel 11.

    If I plug ethernet into the pi there aren't even any WIFI networks listed.

    After restarting it picks up the WIFI fine and works as expected.
    Any ideas what could be causing this?

  • For some reasons the wlan scanner did not see any networks. Hard to say why this happened. It is just a small tool convertig iwlist output if i remember right. You could try selecting never enable ap so even if it does not see your network it will not disconnect, unless linux also has the problem that the runnin9g wifi connection gets closed.
  • Thanks for the reply. If I disable AP mode, and it loses WIFI connection, I won't have any method of accessing the server as I don't use a touch screen.

    I'm going to dig out a wifi range extender I have laying around, and plug the PI directly into this using an ethernet cable. Its not ideal but it fixed all the wifi issues I had when using a PI 2. 

    I find it hard to believe that with a third generation PI with built in WIFI receiver, WIFI connection is still a problem. Especially as it is key to the functionality of most thinks people do with a PI.  

  • We are still testing and improving the wifi handling. Next release will allow to setup ssid/password pairs so it automatically reconnects once it sees a known network if it gets disabled plus some more changes. Much also depends where wifi router and pi are located. In a metal housing the signal gets bad quite quickly for example.
Sign In or Register to comment.