Auto start print from S3D

Hi, I am using curl to send gcode directly to my printer from Simplify3D.  I had it setup on Octoprint to auto start on upload.  I cannot seem to make that work with Repetier.  I tried a bunch of tags in the URL. Has anyone gotten this to work?


  • That is great information.  I am trying to do something a little bit different.  I am using the API to upload my gcode directly from Simplify3D.  It works to upload but I cannot seem to get it to auto start.  I tried changing model to print and job, but that did not work either.  I am pretty sure the functionality is in there, I do not know where to look.  Thanks for the help and below is my command.

    "curl" -i -X POST -H "Content-Type: multipart/form-data" -H "x-api-key: KEY" -F "a=upload" -F "filename=@[output_filepath]" "http://URL:8080/printer/model/T_Rex_2"

  • As our docs say, th ejob version is a bit different. Please note the extra "name" parameter required for it to work!

    "curl" -i -X POST -H "Content-Type: multipart/form-data" -H "x-api-key: <Your API>" -F "a=upload" -F "filename=@[output_filepath]" -F "name=[output_filepath]" "http://<Your IP>:3344/printer/job/<Your Printer Name>"
  • The above statement doesn't work for me.  It doesn't start printing and doesn't upload.  The line I posted above uploads but doesn't start printing.  Do you have any suggestions for me?  I absolutely love the software, I bought the Pro version right away.  I miss the auto start I had working with Octoprint.
  • The line only autostarts if no prints are waiting or being printed. If not it will just queue the file in the print queue. You see it in print panel at th etop if that happens. This is just because there are several files to be printed and it is not clear then whcih one.
  • Is there a way I can clear the queue at when I send the file?  I have the printer stopped.  There are gcodes in the default group.  Where can I find the print queue?  I don't see anything labeled like that.

  • I have tried deleting all of the stored gcode files from the groups.  Still doesn't auto start.  I cannot seem to figure out what I am doing wrong.  By the way I have three printers running on a Pi3 now.  Its amazing, great work.
  • You only see print queue in print tab if it is not empty, otherwise it is hidden.

    Show your link and I might see the error but that is what worked for us while omitting the name part like for model makes it not work.
  • "curl" -i -X POST -H "Content-Type: multipart/form-data" -H "x-api-key: KEY" -F "a=upload" -F "filename=@[output_filepath]" -F "name=[output_filepath]" "http://NAME:8080/printer/job/T_Rex_Plus"

  • Ok this sends full path a sname which might cause problems. We tested windows to linux and ther backslash is not a problem. Maybe your combination sis defferent so sending name only might help here, so try

    "curl" -i -X POST -H "Content-Type: multipart/form-data" -H "x-api-key: KEY" -F "a=upload" -F "filename=@[output_filepath]" -F "name=[output_filename]" "http://NAME:8080/printer/job/T_Rex_Plus"
  • That was it!  Sorry to be such a bother, its a little thing but it saves me so much headache!  I would sent the print and wonder why it wasn't done an hour later... haha

    You guys are the best.  I am recommending your software to my fellow Formbot owners!
Sign In or Register to comment.