Com port 3d printer (maylan 150M)

hello,

i'm been trying to get a raspberry server running with te repetier server, when that finally works as i wanted it to be. i tried multiple times to add my printer, but when i have to slect firmware baudrate and com port i have no idea...

i have about 60 TTY ports to chose and i cant find my printer with "lsusb" so i think my raspberry pi 3b does not see my printer... does anyone know's or thinks what i'm doing wrong?

Best Answer

  • Posts: 0 Answer ✓
    Does not sound so good if 2 os do not see the serial. Maybe ask your printer vendor about that problem. With the printers I know you see the serial regardless if a firmware is installed or not. Ok for windows you need to install the driver but then you should see it in hardware manager.

Answers

  • Server offers them and there is normally only one /dev/serial/... which is the one you want.
  • i only have the:

    dev/tty
    dev/tty1
    untill
    dev/tty63
    dev/ttyAMA0
    dev/ttyprintk

    but i cant vind the baudrate, input buffer size, and even the firmware

    i'm kinda new to 3d printers.
  • Ok that is bad as it means your printer did not show up. For my board it is ttyACM0 but others have ttyUSB0 depending on usb converter.

    Does your board get power? Some boards require 12V from printer while others can also be powered by USB to show up.

    As a counter test you could also try adding it to windows and see if windows sees a new device. In contrast to windows, there is no need to install a serial driver. They are build in.
  • i've actually already tried to put it in my notebook, waited a min or 2 but nothing happend, did not look in my device config but did not get the message that something connected to my notebook....
  • well, i've tried to connect it to my computer... and did not manage to get a good link between them. if u use repetier host and press the connect switch it says it has connection but can't print (like the baudrate is wrong) is there any possibility that my printer does not support this? cause i cant find anything about this printer...
  • Host will also connect to any other serial port and not work. Unplug device and if the com port is still there it it belongs to some other device on the computer. Not knowing that printer I can not say if it is supposed to work. I mean there are several firmwares and not all are supported by us.
  • Well, the site says it is supportd by repetier software, but, I'm starting to think That it is supported by the repetier g-code an That the whole printer does not support USB connection
  • You could check if you see the controller board and compare it with available boards. Then you would see if it is supposed to have arduino supporta nd thus be able to run repetier firmware or marlin and have a com port. On windows you normally install Arduino IDE with drivers and com port should appear when connected.
  • Compatibility Windows, MacOSX, Linux

    Should work right? (Says the wiki of the malyan 150m)

    http://wiki.malyansys.com/doku.php

    Dont know if I am allowed to post link's...
  • They write "Economy metal structure 3D printer. Prusa i3 compatible with Marlin firmware. Plain GCode is directly supported." so yes I assume it should have a com port. As far as I know it is the only way marlin talks with hosts and we support Marlin firmware. So tell your seller printer is defect as it does not show the com port.
  • okay... i've failed big time... i used another usb cable to my notebook and Repetier host worked... shame on me....

    connected raspberry to it en it works now... thanks for your help and sorry for my stupidness...
  • edited February 19 Posts: 8
    well, i've get it working at repetier Host, but if i Connect with Repetier server i cant see tempratures, cant move the printer and cant print... i've have connection so i've manenged a step forward in the past days...
     
    ~edit

    i can see tempratures now, but still cant move or edit temprature...

    11:58:48.595 : Error:Line Number is not Last Line Number+1, Last Line: 10
    11:58:48.595 : Resend: 11
    11:58:48.595 : ok
    11:58:48.595 : Error:Line Number is not Last Line Number+1, Last Line: 10
    11:58:48.595 : Resend: 11
    11:58:48.595 : ok
    11:58:48.595 : Error:Line Number is not Last Line Number+1, Last Line: 10
    11:58:48.595 : Resend: 11
    11:58:48.595 : Resend after 125ms
    11:58:48.595 : ok
    11:58:48.595 : Error:No Checksum with line number, Last Line: 10
    11:58:48.595 : Resend: 11
    11:58:49.383 : Repetier-Server disconnected.

  • Ok, so you have Marlin firmware and it has problems with the communication. Could it be that you have selected repetier-firmware in server printer configuration? That would use a binary protocol your printer will not understand. So please select Marlin as firmware type.
Sign In or Register to comment.