Second Camera doesn't Work on Raspberry Pi B+

Hey I've got two printers I want hook up to my Raspberry Pi B+, I recently updated the Repetier Server installation on my Raspi to 0.80.3 with the online update function. Controlling the printers works fine but the the second cam doesn't seem to work. I'm using two standard Logitech webcams. Each draws 500mA so I tried using them with a powered usb-hub but for some reason only one Camera works. So I can't find the port for the second cam it doesn't even light up to indicate its working. 


  • Are you using latest mjpg streamer helper from us? First version could only handle one webcam, while the one on latest image can handle up to 10.

    Also check if you have /dev/video0 and /dev/video1 in your filesystem when they are connected. These are the device files and as long as linux does not see 2 it also won't work.
  • I have the pi image for 0.80, and just recently upgraded to 0.83
    With only one webcam plugged in, the image is available on port 8080. When I plug in a second webcam (I have two printers configured in Rep-Server), the image from the second webcam replaces the image of the first camera on port 8080, and I can't find the first webcam's image. Is it on a differnt port? I'm not sure where to look.
    I do have both video0 and video1 in /dev
  • Latest image would assign webcam to ports 8080 then 8081 then 8082 if you have a third one. Host should see. That and offer 2 webcams in webcam configuration.
  • Would the image from 0.80 assign webcams to 8080 then 8081, etc? I'm still not having luck. My ipaddress:8081 goes to a dead webpage.

    And then, in the webcam config, I assume you mean assigning a webcam to each printer? I don't see a master webcam config in the global settings.
  • Yiu need latest image meaning with 0.80.3 - previous images had only support for single webcam. Yiu also see in syslog or with ps aux if two mjpgstreamer instances are running, each webcam needs a own instance. The webcams are only visible in printer webcam setup to select from a dropdown at the button. That can then enter the required url if you want to use one of those.
  • I see, that was my problem. I was running the image from 0.80. I used the new image, 0.80.3 and both cameras now have images, one at port 8080, one at 8081
    Thank you for the help!
Sign In or Register to comment.