Repetier keeps shutting down in the middle of a print.

I am running Repetier 1.6.0 on linux mint. It works great except it shuts down right in the middle of a print. I haven't been able to finish any prints.


  • What is your definition of shut down? Crash, reboot linux or just stop printing?

    You could install repetier-server and print from host over server. Server is much more stable on linux then the host and will continue to print if host crashes.
  • I am having the same problem. Version 2.0.5 (if I remember correctly) on Mint 18. No error messages or anything like that, and I ran system monitor to see if maybe memory was being filled up, nothing. The software literally just shuts down and goes back to my desktop. The printer will then reboot and just sits there. Again no errors or anything. I did try running the printer on a spare power supply just to make sure it wasn't something there, same problem. I plan to try a print off the sd card to verify that it is a computer/Repetier issue. The last time this happened (last night) it stuck the nozzle in the part, cooled, then when I tried to home, actually broke the nozzle... As soon as the new ones arrive I will confirm. Printer is an Anet A8, all less than a week old, and the install was a second one as I was thinking maybe I had a bad download the first time, clearly not. 

    I will also try server and see what that does. It's too bad, other than that for a new machine with little tuning, the prints look really good, if only they would finish.

    One final note, this seems to happen randomly. Some prints will go for an hour then die others after 5-10 minutes. Does not seem to be any common factor that I have found yet.
  • If the ui of host shuts down this sounds like a internal crash. If you run it from a console you would see the error message, which would be a help. For testing you could connect to a virtual port and print visrtually. Guess crash does not depend on firmware also you never know.

     If you use server even over host it might crash the host but print would continue.
  • I had similar effects.
    The program was started from the console, and there was several times the same single error line:

    intel_do_flush_locked failed: Input/output error

    Searching the net it appears the error is related to OpenGL.
    My system runs CentOS 7.4 on a Lenovo Yoga 510, the graphic subsystem is Intel® HD Graphics 520 (Skylake GT2)
    Thus I think there is no quick solution. First attempt to work around the issue is to omit the 3D animation of print progress by selecting the Preview tab.

  • You can also disable filament visualization instead. And as a betterfallback print using repetier-server so even if host crashes the print will continue.
Sign In or Register to comment.