another failed install

i got the latest rasbian image and updated it

then with wget i got the latest server package...

but something did nto go right:

pi@raspberrypi:~ $ sudo dpkg -i Repetier-Server-0.80.3-Linux.deb
Selecting previously unselected package repetier-server.
(Reading database ... 121904 files and directories currently installed.)
Preparing to unpack Repetier-Server-0.80.3-Linux.deb ...
Unpacking repetier-server (0.80.3) ...
Setting up repetier-server (0.80.3) ...
Install Repetier-Server
You may see warnings about groups. These can be ignored.
Adding user `repetierserver' to group `tty' ...
Adding user repetierserver to group tty
Done.
adduser: The group `intserial' does not exist.
adduser: The group `ugpio' does not exist.
Created symlink from /etc/systemd/system/multi-user.target.wants/RepetierServer.service to /lib/systemd/system/RepetierServer.service.
Job for RepetierServer.service failed. See 'systemctl status RepetierServer.service' and 'journalctl -xn' for details.
dpkg: error processing package repetier-server (--install):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for systemd (215-17+deb8u6) ...
Errors were encountered while processing:
 repetier-server

pi@raspberrypi:~ $ systemctl status RepetierServer.service
● RepetierServer.service - Repetier-Server 3D Printer Server
   Loaded: loaded (/lib/systemd/system/RepetierServer.service; enabled)
   Active: failed (Result: start-limit) since Tue 2017-01-17 20:56:55 UTC; 4min 13s ago
  Process: 1188 ExecStart=/usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml --daemon (code=killed, signal=SEGV)
  Process: 1183 ExecStartPre=/bin/chown -R repetierserver /var/lib/Repetier-Server (code=exited, status=0/SUCCESS)
  Process: 1182 ExecStartPre=/bin/mkdir -p /var/lib/Repetier-Server (code=exited, status=0/SUCCESS)
pi@raspberrypi:~ $

pi@raspberrypi:~ $ journalctl -xn
No journal files were found.
pi@raspberrypi:~ $

i dont get any clues, where could i find the "fault" ?

Comments

  • Posts: 123
    i picked the RASPBIAN JESSIE WITH PIXEL image and the first thing i did was using raspi-config to make it startup to command line with autologin

    then i setup wifi and disconnected the wired network

    then i did a full update and downloaded repetier server


  • Posts: 0
    You could try starting it as root from commandline and hopefully get a hint where it crashes

    sudo /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml

    also check serverlog in /var/lib/Repetier-Server/logs

    if it contains any information. If it does not succeed try with strace

    sudo strace /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml

    that writes a lot and the end where it crashes shows hopefully it tried to include some library not existent or something like that.
  • Posts: 123
    sudo /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml

    no errors

    sudo nano /var/lib/Repetier-Server/logs

    says new file so it makes me think it does not start

    sudo strace /usr/local/Repetier-Server/bin/RepetierServer -c /usr/local/Repetier-Server/etc/RepetierServer.xml

    output from that here, and it did only confuse me:

    http://pastebin.com/pnSxziyY

  • Posts: 0
    armel is at least compiled on a pi. Armhf normally owrks on Pi 2 or newer, but not on Pi 1. So yes, would be a test.
  • Posts: 123
    that worked... its a pi 2 so hmm... oh well

    i got it down to :

    pi@raspberrypi:~ $ sudo update-rc.d RepetierServer defaults
    update-rc.d: error: initscript does not exist: /etc/init.d/RepetierServer

    have used this guide as a "helper".... i guess i have to reboot and manual start it each time?
  • Posts: 123
    well after reboot and starting the service it does not work so well.

    will check if service is running at all

    changed it to port 80 so that i did not have to add the port number all the time
  • Posts: 123
    oh well it works on port 3344

    guess i can learn to live with that

Sign In or Register to comment.