OpenGL/Graphics card not detected


I upgraded to the latest driver (version 376.33) for my NVIDIA GeForce GTX 860M graphics card but after doing so Repetier Host cannot detect OpenGL and/or graphics card properly. I tried re-installing the driver to no avail. The output window shows the following at start up:

11:50:11.531 : OpenGL version:1.1.0
11:50:11.531 : OpenGL extensions:GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
11:50:11.531 : OpenGL renderer:GDI Generic
11:50:11.531 : Fast VBOs for rendering not supported. Using slower default method.

If I remember correctly, before upgrading the driver it used to print the name of my graphics card and OpenGL 4.5 etc. I have tried to use other OpenGL applications since upgrading the driver and they work fine.

I am using Repetier Host 1.0.6 (have not had any reason to upgrade because it has been stable), could upgrading to the latest version help? I rather not upgrade at this time unless it is sure to fix this problem of course.

If I start Repetier Host with my integrated graphics (Intel HD4600) Repetier Host prints the following:

12:04:21.660 : OpenGL version:4.3.0 - Build
12:04:21.660 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr (...a long list...) 
12:04:21.679 : OpenGL renderer:Intel(R) HD Graphics 4600
12:04:21.679 : Using fast VBOs for rendering is possible

So here the detection works but unfortunately the 3d related stuff is very slow with the integrated graphics.

Any ideas how to fix?


  • The detection is done in the OpenTK library, so we have no direct influence on this. Dual graphic solutions have always been a problem with that. You could try using the other OpenTK version (legacy) on install and see if that detects the card better.

    I see they work on a new version 2.0 which maybe also solves the problem, see

    You can simply copy the opentk library to the install folder in c:\Program files\Repetier-Host replacing the existing ones. If they haven't made it incompatible it should work. Please report if that works better so I can replace the version on next update. I have unfortuately no pc with dual graphic card for testing.
  • I did some tests with OpenTK in Visual Studio and discovered this:

    Using the NuGet package called "OpenTK" (latest version: 2.0.0) my test application printed the following:

    OpenGL version: 4.5.0 NVIDIA 376.33
    OpenGL renderer: GeForce GTX 860M/PCIe/SSE2

    Using the NuGet package called "OpenTK.GLControl" (latest version: 1.1.2349.61993) my test application printed the following:

    OpenGL version: 1.1.0
    OpenGL renderer: GDI Generic

    So the first one works but the second one doesn't (same with Repetier Host). I don't know what the GLControl part does but Repetier Host seems to use it.

    For my integrated Intel HD4600 graphics card both test applications print the following:

    OpenGL version: 4.3.0 - Build
    OpenGL renderer: Intel(R) HD Graphics 4600

    Is it possible to get the legacy version without re-installing Repetier Host?
  • Reinstalling will not change configuration, that should be no problem.

    Alternatively just copy the other OpenTK version files into install directory.

    GLControl is unfortunately the window for OpenGL where it appears. Alternative is full screen which makes no sense if only a region should contain a openGL. Since full screen means no windows controls and full screen controlled by graphic this may contain different possible graphic modes then within the window mode. Or the detection for window mode is not as good as the one for full window.

    But the result is at least very interesting showing that it should work if GLControl would do a as good job as the other solution. Can you send the 2 test programs you used. Seems a good starting point to see if I get the difference. Maybe I then can compile my own GLControl version and send you for testing. Seems like you know what you are doing, so that might be a big help to solve this issue for all.
  • I did some more testing with GLControl, I managed to get the detection to work in these two scenarios:

    1. Using OpenTK.GLControl version 1.1.2349.61993 then upgrading OpenTK to version 2.0.0.

    2. Using OpenTK.Next.GLControl and OpenTK.Next.

    I sent you a message with my test projects.
  • Hello I am having exactly the same problem. I am using Repetier Host ver.  1.6.2 and just build a new desktop computer.
    It's a new i6 kaby lake 7600k with Nvidia GTX 1070 Windows 10 pro and after installing new nvidia driver the Repetier Host can't recognise the Open Gl.
    I remember that with the older nvidia drivers I had no problems at all. 
  • Ok then it is not just me. Do you also have Intel's integrated graphics that you can use instead but with much worse performance?

    I have not managed to substitute the OpenTK libraries that don't work with the ones that work with my test projects because Repetier Host crashes at start up. It would appear Repetier Host has to be rebuilt with these new OpenTK libraries in order to get it working on our machines.
  • Just a follow up. dbostream has confirmed that rebuild version works, so with next host release the problem will be fixed. Hope to release it in february.
  • edited January 2017
    Repetier said:
    Just a follow up. dbostream has confirmed that rebuild version works, so with next host release the problem will be fixed. Hope to release it in february.
    Good I look forward to the release. I will continue to use my old version for now as I am not sure if you consider the new test version I got stable or not. I just have to remember not to zoom in on the sliced models and rotate because with my integrated Intel graphics it will stall the printer.
  • The version you got is stable. I'm just in th eprocess of updating the design that should not add stability issues.
Sign In or Register to comment.