Display, Wifi, and Pauses

I have the raspberry PI 3 with 7" touchscreen and been performing some tests using both the prebuilt raspberry pi repeiter server image and installing on raspbian jessie with pixel (https://www.raspberrypi.org/downloads/raspbian/).  My plan is to find the most stable configuration and stick with it.

When using the prebuilt image I keep having the touch screen display go dark like the screen saver has turned on and won't wake back up with a touch.  I can still access repetier server over the web interface and ssh into the system.  What can I do to kick start the touch UI again short of restarting the pi?  I can attach logs to help debug just let me know.

When using the prebuilt image wifi will drop out and not come back on it's own.  To fix as it is usually during a print I usually connect via ethernet or by the touch ui (if it is working at the time) and reconnect the wifi.  Currently I am trying the fix which is to comment" # nmcli connection delete "$P1" ifname $WLAN  &> /dev/null" and so far so good.

When using raspbian jessie and the armhf build  I don't have the touch screen timeout / black out issue or the wifi issue but I do have the problem where printing will pause for 10 seconds or more causing a large defect to appear on the print.  I am running three printers off of the pi and it doesn't matter if only one, two, or all three are being used at the time I get random pausing.  When there is more than one printer operating they all will pause at the same time.  So far I haven't noticed this problem with the prebuilt pi image.  I have tried everything I can think of from setting the buffer size to 96 to match the printers firmware configuration (the marlin default) to tweaking with timeout values and even modifying the printers firmware (lower baud rate, larger buffer, etc..) nothing seems to work.

Let me know if you want logs or further information.  At this point it is easy to switch between the two builds (swap SD cards).



  • Well the strangest thing happened.. The touch screen had timed out and I could not wake it up.  Well a few hours later my four year came by and started poking at the display and wouldn't you know the display woke up.  Ever since then it has been timing out and waking up fine.  I haven't rebooted the pi yet to see if the problem happens again after a reboot but for now it is working.  Who would have figured... leave it up to the small pointy fingers and curiosity of a four year old to solve my display problems.

    I will keep you posted if anything else comes to light.

    - Robert
  • Well the black screen of death has come back.  It started happening again before I had a chance to reboot.  One thing I have noticed is that even though the display is black I can touch the display and it seems to be operating the controls of the last page I was on.  So the UI is still running if that is a clue to what may be going on.

    - Robert
  • Actually the server is not responsible for the screensaver, that part is handled by linux/X11 it self. All we do is setting the timeout value and activate /disable screen saver. So if you go to screensaver icon you could disable the screensaver. So we only call 3 xset commands to tell linux to enable/disable screensaver. In addition if enabled we also put a dark cover to prevent first hit executing a function after screensaver should be enabled. So question should be why does linux not activate screen sometimes for some users. We have two 7" displays without that problem so far or smaller fingers:-)
  • Hi

    I had this exact problem on my RPi3, screen backlight doesn't wake up but the touch panel works.

    I read somewhere(I can’t remember where) that certain kernels does have bad support regarding this exact problem.

    So I tried to upgrade the kernel, and since I have not had any problems with it what so ever.

    This upgrade will not alter anything on the installed OS, and you can even upgrade it while the server is in use (I upgraded mid print) but it won’t take effect until the RPi is rebooted.

    First, update your systems package by entering: sudo apt-get update
    Next, upgrade all your installed packages to their latest versions with the command: sudo rpi-update
    (if rpi-update is not installed you can install it using: sudo apt-get install rpi-update)
    Last, Reboot

    Hopefully this helps
  • Note that upgradingonly works on the newer images from us if you used an image. New x server had incompazibility and required an additional package to get ui working again. Newer images have this fix already included.
  • if you du a uname -r you will see what kernel release you have.
    Mine was 4.1.19-v7+ when I encountered this problem, and this was specified as one of the releases that had problems with screensaver.
    My current release is 4.9.40-v7+, and ths works like a charm
Sign In or Register to comment.