Three Issues I have had

I have been using Repetier-Server on my raspberry pi 3 with 7" touch screen for a few weeks now and I have had three problems and or possibly bugs.

1 - Using the prebuilt raspberry pi image sometimes the 7" screen will time out and won't wake back up with a touch.  This was annoying enough that I installed Raspbian and setup Repetier-Server and setup the UI in Kiosk mode.  I haven't had the screen timeout issue using this method.

2 - I have three printers which I have been using with Repetier-Server.  A Prusa I3 MK2, Wanaho Duplicator 6, and Tevo Black Widow.  It seems if I run two prints in a row with the Tevo Black Widow it isn't running my entire startup script located in the gcode file on the second print.  If I cancel and restart the print it will work then fail on the next print.

3 - I have setup samba on the raspberry pi and save my gcode to a folder on the pi.  This makes it quick to import gcode from that folder when printing on Repetier-Server.  One of these prints I imported and didn't wait for the preview image as usually takes a while.  Well for some reason it didn't end up importing all the layers.  Only about 30 percent was imported and unfortunately I didn't find out till the next morning with an entire bed of partially printed parts.  The gcode from the import directory was complete but for some reason it didn't import all layers.  I have only had this happen once so far.  It was fine after a second import.

Could there be anything that I have done wrong that could be causing these issues?

- Bob


  • 1. Never had this on my Pi touch screen constantly running. Are you sure the pi was not just simply crashed? The sleep handling has nothign to do with the server itself. All we do is using xset to set timings for screensaver and ignore first touch in our ui to not activate a function that was invisible.

    2. Sound like this does not happen with the other 2 printers. Is that so? What does the gcode contain and for which firmware? Generally it always runs teh same function for all gcode scripts, so I wonder why or what might prevent it to not work on second try. So please give the gcode and if possible say from where on it is being ignored. Server validates gcode and does not send invalid gcode so maybe something causes it to trigger that. Might also be an effect from the end gcode preventing the next start gcode to not work properly, whcih explains why it does not work on second print. Would disconnect/reconnect make it work also on second run? Have you tried logging and saw that the lines did not get send?

    3. gcode gets copied again from import for printing and afte rprint that file gets deleted. So hard to say afterwards why it did not get copied completely. Might be error on sd card, while copying or something else. 
  • Here is an update.

    1- The UI might have crashed but the print was still running and I could access repetier server over a browser on the network fine.  I will give the prebuilt image another go and look to see if I can collect more info if it happens again.

    2 - looking at the comm stats it would occasionally show errors.  I ended up comparing printer settings with the other printers and the Black Widow had a communication timeout of 3 seconds while all the others had 30.  I changed the timeout to 30 then modified the printers firmware to use a lower baud rate (115200) and increased rx buffer size.  It seems to have helped as I haven't had it go haywire since the changes.

    3 - It very well could have been the SD card because three days later the card went into a read only mode that I have been unable to reverse.

    4- One new issue I have had crop up last night happens every 5-10 minutes or so all three printers will pause for 3-10 seconds then resume.  Running the utility top from the command line during this event shows RepetierServer using >=120% CPU during the pause event.  This has a tendency decrease the quality of the prints as it puts a defect wherever the print will pause.  Once this print session is finished (another 10 hours) I will give the server a reboot and see if it clears up.  I might go back to trying the prebuilt image on another SD card and see if it crops up there.

  • Running 3 printer in parallel can cause higher cpu load depending on what else apart from printing has to be done. There is a too htop (apt install htop) that can show cpu load of the threads. Do you also have 3 webcams and store data as timelapse? Were you running out of memory?

    The pause indicates that there is a bottleneck sometimes. A pi 3 can have 400% cpu usage so 120% is not the real problem I think. But if they block each other as they wait for something then you will get a pause. Normally all tasks are blocking only very short so you have no problems. Swappign out memory or starting a external program might block sd reading a bit, also we buffer 5000 lines in advance so the block must be quite some time to empty that.
Sign In or Register to comment.