Can Connect but not communicate with printer

I have a new Tronxy P802MA printer.I can see the printer stats but it will not respond to my commands, I am using Windows 10 repitierserver and host ( 1.6.2). In repetier I can connect to it and I can see that it is trying to run commands but my printer isn't doing anything and won't communicate. When I try and send a print I get the error "No start signal detected - forcing start" and then “communication timeout - reset send buffer block” when I try and manually control from Repitier Host It says command waiting and gives the same error. I've gone through the setup wizard and it still doesn't work.

The printer uses a Melzi 2.0 board (ATMEGA1284P)

Tried all the different baud rates available. Downloaded the FDTI drivers and reinstalled. Looked up the counterfeit FDTI chips and mine seems legit
Tried multiple USB cables
Tried 2 separate W10 machines

Any suggestions or Ideas ?


  • Try different baud rate. Or force 115200 baud in firmware and check with arduino serial monitor if you see anything if you hit reset on printer board.
Sign In or Register to comment.