Trouble setting up rasp pi with repetier server

Hi, i'm new to the forum and spent some time looking around for a solution and but had no luck

I'm trying to set up a rasp pi as the server for my reprap Prusa 3D printer.  I used the wget command to download the most recent armhf file (0.80.3) and then sudo dpkg and sudo service RepetierServer start..

I then opened my browser and typed the local IP address in but received a could not connect error connection refused.  I tried the local IP address followed by both :3400 and :80.. The :80 came from another tutorial I tried to follow with little help.

Any idea what I could be missing??

Stephen

Comments

  • Well correct ort is :3344 not :3400.

    If you use the server image for pi it is a bit easier as it has webcam/wlan already setup and :80 also works.
  • I did try using the precompiled sd image for the  raspberry pi, and it booted immediately, but I have now found a new issue for my set up,  the attached screenshot shows what I cannot get past and seems to not be connected to the printer..



    any idea what i should do next?
  • What resolution has the display? Looks like it did not fit perfectly so it must be a unsupported resolution and it fall back to biggest supported value fitting into it. But adding that resolution for next update should be no problem.

    What you do next is configuring the printer in the normal web front end. Once that is configured it will auto connect and you get all the extra buttons. Make sure printer is connected to pi when doing that. Web frontend has a configuration wizard that should put you easily through install process, read manual for more infos about this.
  • the screen resolution does need to be corrected, i'm unsure what it is exactly but I do have some code for the pi to correct the config.txt file..

    After I connect the printer to the pi, do I setup via the web front end on the pi or on another computer?  I can't move off from the screen in the previous screenshot if it needs to be done via web on the pi..


  • No you do it from a different browser. If you click on Network icon it will show possible urls. If your browser is one of these networks it should work.
  • are you saying to click on the network icon shown on the pi?  I'm unable to navigate this screen even with a mouse for some reasons.. 

    also the screen resolution was 800x480, and resolved after editing /boot/config.txt
  • You should have configured it for touch screen support. The displays normally have a document describing how to set up touch screen navigation as every one has it's own solution.

    If you would then select the entry you would see the ip addresses assigned. Of course you can also ask your router or use a network scan utility to see which address it could be and try to enter http://ip on your browser. Ot if the os supports bonjour simply select http://repetierserver.local ;
  • Posts: 7
    Thanks for your help, I followed your instructions more closely and have made great progress accessing the 3d printer now..

    I was printing earlier, but am not not able to control the printer from the server (hot end does not heat up, and motors were moving but not now).. where should i start to correct this issue?? any ideas??
  • Posts: 0
    Always start with the log. See if communication is going and if commands get send. It should also show if firmware stops for some security reasons like defect heaters, ...
Sign In or Register to comment.