Auto update fails


Auto update is not working for me on a PI. I tried to update from 0.80.1 to 0.80.2, clicked the auto update button yesterday evening but no responce from the server this morning. Restarting the server gave me the 0.80.1 version. Tried again, been to work and came home, still nothing. It seems to start updating, gives the message that the page will refresh after the update and then it drops the connection and never come back.
Running server Pro on a PI2 with a fresh PI image 0.80.1.


  • Yes, we learned that the new systemd kills the server and this kills installer as well so it fails. Run on commandline shell

    sudo /usr/local/Repetier-Server/bin/RepetierInstaller

    instead and it should update correctly.
  • sudo /usr/local/Repetier-Server/bin/RepetierInstaller
    Gives me;

    RepetierInstaller V1.0
    (C) 2015 Hot-World GmbH & Co. KG
    Repetier-Server 0.80.1
    Configuration file not found at
    Please use config option with correct path

  • Sorry, forgot one parameter:

    sudo /usr/local/Repetier-Server/bin/RepetierInstaller /usr/local/Repetier-Server/etc/RepetierServer.xml
  • that worked for me, thankyou!

    /of course I found this topic only after getting confused what the SD-Image actually is (amhf, armel ?) and -obviously- I ignored the big red warning on the download-page ;-)

  • NO the warning came after your thread, also I realized the problem a day before. Still a bit unclear how to solve it for later versions - seems like linux always want's to kill installer while updating from server - but search continues.
  • Autoupdate to 0.80.3 still won't work for me. Looks like it downloads and give me the text "update info read...Update file loaded and verified.." after that it drops the connection and never come back. Didn't do a manual update in case you want to test something.
  • No from 0.80.3 on autoupdating works. Since you still have 0.80.2 it is ok that it does not work. You need to update to get the working version.
  • Yeah, stupid me, realised that after posting :)
Sign In or Register to comment.