Print and temperature freeze stuck in a loop

Hi, I have a Printrbot Plus connected to a raspberry pi running Repetier-Server 0.80.
I just switched to the SD image to add a raspberry cam to my setup but since then I can't launch any new print.
Here's how it goes:
1 - launch print
2 - extruder/bed heat up fine
3- print start and autoleveling takes place
4- print and temperatures functions freeze and nothing moves anymore.

At this point, I can stop the print that's frozen but it won't give me back command of the extruder or temperatures. The printer's temperatures monitor on the server's home page doesn't shows anything either.

I think I found the cause when I looked at the consol which seems to be stuck into a loop but I don't know what to make of it:
1:13:22.665: Resend: 67
1:13:22.681: Error:Line Number is not Last Line Number+1, Last Line: 66
1:13:22.681: Resend: 67
1:13:22.698: Error:Line Number is not Last Line Number+1, Last Line: 66
1:13:22.698: Resend: 67
1:13:22.698: Resend after 141ms
1:13:22.713: Error:No Checksum with line number, Last Line: 66
1:13:22.713: Resend: 67
1:13:22.725: Error:Line Number is not Last Line Number+1, Last Line: 66
1:13:22.725: Resend: 67
1:13:22.742: Error:Line Number is not Last Line Number+1, Last Line: 66
1:13:22.742: Resend: 67
1:13:22.759: Error:Line Number is not Last Line Number+1, Last Line: 66

Any idea ?


  • Looks like you are using Marlin and the command send in line 66 makes problems. So please activate logging in printer context menu and start print. If it is a problem with a special command it will fail again also line number may vary. But now you can see in the log file what that line was and we can better discuss what the problem is and maybe fix it for next release if it is on server side.

    Also what firmware exactly are you using? Download site and version. Marlin has so many forks that they might have different behaviour.
  • what the... it started normally when I tried today. only difference was that I activated the logs...
  • Printrboard has one problem in that it never resets. So the problem might be from a older connection being in some error state. One reason why we prefer resetting firmware on connect. In most cases no problem and unpowering printer including board (disconnect usb) would always solve such a problem. I don't think it is log related.
  • yeah, the log most likely doesn't change anything. I just pointed out that it was the only change done.
    as for the reset, I had turned off/on the printer many times before coming here.

    well, it works now. thanks for your time.
  • I had the issue again several times.
    here's the log file of the latest tentative print (already 3 times that I'm trying it) & Feet 4 sizes.log?dl=0
  • @Weaper What release are you using? In your log I see
    M117 ETE 08:27:31
    with : which can cause problems in Marlin since older Marlin versions do treat this as a new line. Your resend is a fe lines later, so I'm not sure the resen loop is related to that or not. You can disable this in Printer Configuration->General -> Show on printer LCD to none.
  • edited November 2016
    I use the latest SD image disk released. And indeed, I don't have any screen on my printer (Printrbot Metal Plus)
    I'll make the change you mentioned  
  • So, that's not what the issue was...
    The reason for my delayed response was that most of the time it only did that once or twice but rebooting the rasp was enough to set it straight. However today there is simple no talking it into working.

    Any other idea as to what could cause that loop? It's a real pain
  • I just remembered that I had an old version repetier server installed locally, the 0.65.0
    I tested a similar gcode and the print started immediately... I guess it has something to do with the latest version then? Maybe a compability issue? an idea?
  • So this happens only on connect?

    One problem of printrboard is that it does not reset on connect. On startup server send reset of line count M110 N0 but if Marlin does not accept this and wants line 67 which is not available at startup as it comes from previous connect you get into this loop. A simple reset on the printer board should make it connect then.
  • edited November 2016
    The more I face this issue and the less it seems to come from printrboard.
    Here's what leads me to think that:
    - repetier server 0.80.0 on raspberi pi is stuck like never before. impossible to print anything, starting a new print launch the print that first froze it.
    - repetier server 0.65.0 on local print like normal.
    - going back to the repetier 0.80 on the rasp afterward and it's still stuck with the same print even though the Printrboard printed something else with the repetier 0.65 on local 
    - rebooting the server stops the loop of Error/Resend lines in the console but starting a new print brings it back

    for both, same printer and connections. Rebooting or unplugging the rasp with the 0.80.0 doesn't change anything.
    I'm to my wit's end. I can't have my laptop chained to my printer for many hours
  • We have found one thing that prevents/disturbs reconnecting on current server release. It's already fixed in dev version for next release

    which hopefully works like 0.65 in that part. Wil test with printrboard before final release.
Sign In or Register to comment.