communication timeout after powering up

edited October 2016 in Repetier-Host
I bought a new arduino mega 2560 with ramps 1,4, uploaded firmware that worked on last one and all worked, then I used new (tested with multimeter) 12V power supply. From that time everytime I try to connect to computer it only blinks and repetier-host says communication timeout. I tried reuploading firmware, but arduino IDE says the same... communication timeout. I tried reinstaling driver, also alternative drivers for this type of board, but same. I tried all other baud rate setting, but same. And I tried this all on two separate computers (one have got Win10, other one Win8.1) Please what else can I even try? Or how can I avoid this to happen next time?


  • Was polarity of PSU correct?
    Does it still persists if you connect without PSU?

  • edited October 2016
    It was, there was only problem with isolation could it be it?, yes it persist
  • Check if you can still upload new firmware or other programms. Just to make sure communication in general is working. If that does not work you might have destroyed something somehow.
  • I can't upload programs to that arduino, but when I connect display I can controll the printer with it, so only problem is comunication with PCs.
  • Communication uses a different chip. If that is not working any more you can not communicate. Some have problems with fake FTDI chips that can stop working if the original driver detects them, but Arduino Mega does not use them.

    You could put off ramps board and try uploading simple blink sample program, just to be sure it's not some problem coming from the RAMPS shield. If it is impossible to upload even the smallest program then your board is defect or USB converter flash is corrupt. If you have a ISP you can upload the firmware yourself. But at the end I fear something is defect.
Sign In or Register to comment.