Informer App receives notifications but none listed in app

I just recently started using the Informer app for Android. I have Repetier-Server 0.75 running on a RPi3. I successfully created a group on the phone and entered the group ID in the server. The test message sent a notification to the app. In the notification on the phone, it said Test Notification, or something similar. But nothing listed in the app, just a blank screen (says Repetier-Informer at the top and has the 5 icons across the bottom).

So when a print is finished, my phone gets a notification saying the print is finished (in the notification pull-down drawer). But still the app has a blank screen. Do I need to change a setting? Should the notifications be stored in a list in the app? 
Thanks for the help.


  • Yes, there are 2 parts. One sending the push notification and one polling the server for full data that would appear in the app. Maybe some in database got not set correctly. Try deleting group and create a new one and check if it then appears.
  • I deleted the group in the app on the phone, created a new group. Insert the new group ID in the server settings (interestingly, the ID disappears immediately after I finish typing the whole code, but its there if I leave the setting screen and come back).
    But I still get the same behavior. Notification on my phone (which is great, even has the message info in the notification), but nothing listed in the app. The app looks as if it has not received any notifications.
    BTW, I have a Google Pixel with the newest Android 7.1. Might that be making the app not display the messages correctly? I should try on an older phone.
  • We don't have a Android 7.1 phone so I can not say if that is a problem. The app is a Cordova/Javascript based system so as long as they don't change existing API to not work it should work. Tested with Android 6.01 and it worked. If you have a older phone, please test and let us know if that works.
  • I tried the app on an older phone and it worked correctly. Its a Moto G 2nd gen (don't know which version of Android), but I added my existing group to that phone and sent some test message from the server. Both phones got notifications, but the older phone actually displayed the notifications in a list in the app. The new phone had a blank list. 

    Looks like Google gave you another bug to squash :/
  • Thanks for the update. Will try to find the reason in near future somehow. Hope it also shows up in a simulator.
  • As a note I have the same exact issue on my new Android 7.1 pixel xl. This worked fine on my old Android 6 moto. I'm running the latest server 0.80.3 pro. Hoping you find a solution soon as I'm really struggling with long prints and could use the push updates in the app
  • Looks like one of our android handys should receive a 7.x update this year so we can check what is different.
  • This year? I can put my Pixle in dev mode and send you any crash logs or details you need. I may also be able to get other devices to verify. Let me know if i can help here
  • I will first test with 7.1 simulator. I'm quite sure that push messages do not work there but luckyly the problem is the other half:-)
  • Ok, after long work we think we managed to create a updated version that also runs on Android 7. At least in our simulator it worked. So would be great if you could test if version 1.1 now also works on real world Android 7 smartphones.
  • @Repetier, confirmed this is working with both my repetier server installs.  one on a pi3 the other on a pi2 and android 7.1.1 on my Pixel XL.  I'll set some prints off later and continue validating, but looks good so far!  Nice intro screen btw ;)
  • Confirmed this has been fixed. Thx for addressing this!
  • Second confirmation that the updated app works on a Pixel with Android 7.1.1.
Sign In or Register to comment.