dnsmasq error on raspberry pi b+

edited October 2016 in Repetier-Server
I have flashed the latest image to the raspberry pi and I keep getting these errors when booting. I am then brought to a browser screen saying refused to connect. I am connected through ethernet and I am using the HDMI port. I am able to ping the pi successfully on my network.
Pictures of error messages
The slideshow section is hiding the error message in the 3rd picture. IF you click on the imgur logo in the top left it will bring you to the full pictures.


  • Our first upload of 0.80 had some arm7 instructions not supported by pi 1 so I guess that is main reason why it does not work. The armel package is now updated with a version also running on pi 1.

    We are also working on a new image file with pi 1 support.

    If you try to run main app on pi 1 - don't do it. Use 
    which is less resource hungry and made to work on pi display.
  • Ok so how exactly do I do it?
  • New image is now available and should work also on pi 1.

    Check how graphic works - if it is ok leave it otherwise follow instruction on image download page on how to disable it.
  • Solved this problem, made an account just to share it. Struggled with it for to many hours.
    Basicly what is happening is that the repetier server is choosing the wrong network interface to connect with.
    Instead of using eth0 its using the loopback interface.

    Conencted to my rpi 2 repetier server with PuTTY.
    Connect to its ip using port 22 and SSH.
    Open /etc/network/interfaces by entering,
        1. cd /etc/network
        2. sudo nano interfaces

    remove the loopback line and instead of auto loopback interface set auto eth0
    save and reboot the pi

    Thats how i solved it, might work for you if you happen to have the same fault as me.
    The fault appeared when i started my server without any ethernet connection.

Sign In or Register to comment.