slice3r print offset with printrbot simple metal


I have problems when I slic3e from Repetier: the prints would show in the center in the preview but would print with offset 25x25mm (with Printrbot Simole Metal).  When I invoke the same slic3er stand-alone and then import gcodes to repeater it would show with offset but print in the center.

Also noticed the Repetier overwrites printer parameters when slicing ie the default printer's parameters are not used by slic3r (e.g printer center is ignored) - could it be that printer definition params Repetier supplies to slice3r are wrong?



  • Make sure Slic3r and host use the same printer dimension. The host recalcs position so it is positioned exactly where it should be after slicing. I'm not really sure what goes wrong for you, but it might have to do with different definitions of the center point. There is also an option to add an extruder offset in slic3r which should be 0,0 for single extruder.
  • This happens to a lot of people including me so it's definitely not something michkrom alone is experiencing. Not sure what is wrong. When issuing manual gcode commands to send the print head to the center of the bed of my Metal Simple with:

    G1 X76 Y76

    The print head does center perfectly but when printing that same command seems to behave differently. All of our prints end up shifted 10mm off center in both the x and y directions. If RH can please explain what settings are necessary in both RH and Slic3r in order for prints to come out centered it would help a LOT of people.

    The only clue I have is when the G29 bed probe command says this:

    20:52:00.162 : Bed x: 10 y: 143.00 z: 0.65
    20:52:04.422 : Bed x: 10 y: 10 z: 0.27
    20:52:08.572 : Bed x: 143.00 y: 10 z: 0.38
    20:52:08.572 : echo:endstops hit: X:0.00 Z:0.38

    However the print head is NOT where it is reported to be. This is what it should say as measured by calipers and as reported by M114 is:
    20:52:00.162 : Bed x: 0 y: 153.00 z: 0.65
    20:52:04.422 : Bed x: 0 y: 0 z: 0.27
    20:52:08.572 : Bed x: 123.00 y: 10 z: 0.38
    20:52:08.572 : echo:endstops hit: X:0.00 Z:0.38

    I'm not sure if this is a clue.

    Here is what most of us have tried for the Printrbot Metal Simple which has a 6"x6"x6" build area:

    X min = 0
    Y min = 0
    X max = 152
    Y max = 152
    Bed Left = 0
    Bed right = 0
    Print area width = 152
    Print area height = 152
    Print area depth = 152

    [printer:Simple Mtlconfig]
    bed_size = 152.4,152.4
    end_gcode = M104 S0 ; turn off temperature\nG28 X0 ; home X axis\nG28 Y0 ; home y axis\nM84 ; disable motors
    extruder_offset = 0x0
    gcode_flavor = reprap
    layer_gcode =
    nozzle_diameter = 0.4
    print_center = 76,76
    retract_before_travel = 2
    retract_layer_change = 1
    retract_length = 1
    retract_length_toolchange = 0
    retract_lift = 0
    retract_restart_extra = 0
    retract_restart_extra_toolchange = 0
    retract_speed = 30
    start_gcode = G28 X0 Y0 \nG29\nG1 Z5 F5000
    toolchange_gcode =
    use_firmware_retraction = 0
    use_relative_e_distances = 0
    vibration_limit = 0
    wipe = 0
    z_offset = 0

  • I believe I have found the problem. The offsets stored in my M212 command were:

    M212 X20.0 Y0.0 Z-0.5

    The X20.0 was throwing things off. This happens ONLY after you execute G29 to probe the bed. If you home the extrude using G28 the offsets are reset.

    If you are having trouble with off-center prints on the Metal Simple execute M502 to check your settings. Make sure M212 is set to X0.0 Y0.0. If you need to update this you need to do M500 to save it.

    Once this is confirmed it's a good idea to check the bed settings in RH, Slic3r etc. to make sure they are correct too.

  • You can also set offsets in the host in Printer Settings->Extruder so it shows the same behaviour as your print. But for 1 extruder printers I think offsets should always be 0. I also think firmware should handle offsets internally and not with complicated offsets added by slicers, but I know marlin works different.
Sign In or Register to comment.