server won't activate printer

Since I had to order a new thermister I decided to loose my ramps/mega and get a RAMBo.  I'm able to connect the printer via usb and print with no problem but can't connect via the server.  The host connects but the server tab says the printer is deactivated while the manual control tab says its disconnected.  I've gone over all my server settings and I'm sure they're correct.  I was able to print via the server with the ramps/mega set up before my thermister blew.  When I go to the server I can deactivate the printer and the printer goes white.  When I try to activate the printer it goes orange.  Can't figure out what the issue is.  I've also tried resetting the RAMBo with no success. Haven't found anything searching the web or RAMBo web site.

RAMBo 1.3L
Raspberry Pi
baud is 250000 (same as firmware and eeprom)
selected repetier firmware
/dev/tty.USB0 port

Appreciate any help-


  • Orange is a in between state - it connected to the port you said but did not receive a sign that communication is possible, meaning it's waiting for "start" or "ok" from commands send. This is only tried when activated and continues to try. So normally you should see the printer reset every now and then. So first check should be if port and baud rate are set correct in server. Normally you select the /dev/by-serial/.. port which is more unique then ports under /dev directly.
  • I've checked all baud rate entries and they are all 250000 as they have been all along.
    I used the /dev/tty.USB which is what the server setup program prompts me to use for linux. I have noticed that I used a "." after the tty which I've seen isn't used on other web sites. I've tried with and without the . with no luck.
    Sorry but I'm not programming literate. I don't follow what you're telling me in the last sentence. I want to try the "by-serial" suggestion but don't know how to enter it. Would I actually enter "by-serial" or do I enter some other information there? And what goes after it, USB0? So would I enter "/dev/by-serial/USB0"?

  • Don't enter port names yourself. Click on the Ports dropdown and select your port. Port are special files located in /dev on your harddisk so any error makes it not select right port. There you should see a /dev/serial/by-id/... file at the top which is normally your printer. 

  • That must be my problem. I thought the /dev/tty.USB0 was originally in the server drop down menu but now it doesn't show up. My only choices are com3, virtualdelta and virtualcartesian. Did I corrupt something?
  • As a follow up I Uninstalled and reinstalled server on my computer and still only get the same 3 choices in the drop down menu. Any suggestions on how I can fix this?
  • Ok, looks liek you are using windows. On windows the Port names are named COMx so COM3 should be your printer assuming you have installed the usb-serial driver. Only unix systems use /dev/tty... and all the other stuff I wrote.
  • I have installed the usb serial driver and when I connect the printer to the laptop with a usb cable I use com6. The printer works fine like this.
    I'm trying to connect wirelessly to thr rambo board via raspberry pi. The only choice I have in the server drop down besides the 2 virtuals is com3. Nothing works.
    I had it working wirelessly once upon a time with my ramps/Mega. If I'm not mistaken when the controller is connected via raspberry I need to choose the /dev/tty.USB0 port, no? I recall having many more choices in the drop down menu. Many Com ports, dev ports and others. Is something corrupt in my installation? I've reinstalled server and still only have 3 drop down choices. Is there some sort of recovery file that's corrupt?
    Any other suggestions? This is really frustrating. I'd like to get it working.
  • One other thing. When I choose com3 in server and I try to activate the printer it goes from orange to white.
  • Your description is a bit confusing. If you connect the rambo to the pi you need to run the server on the pi. Since you see COM3 it can not run on a pi, but runs on windows. So I'm currently guessing you are configuring windows config while connected to pi and that can not work? On pi it would in deed be something like /dev/tty.... but it knows drivers so it would definitively appear in the list.

    If printer goes to grey you deactivated it so it even does not try to connect any more.

  • Removed the windows server and everything is working.
    I bought the server pro version yesterday but can't find instructions on how to install on raspberry pi. Is it the same as installation of the free version? Do it via the pi terminal?
    Will that bring up the registration menu for the menu key?
    Last, the download link seems to reference version 70, isn't the new version 80?
  • Last version is 0.75. 0.80 is coming soon. Installation is from terminal like described in manual:

    To install a new version of Repetier-Server download the version matching your computer and open a terminal and go to the download directory. There you enter:

    sudo dpkg -i NewRepetierServerVersion.deb

    After this, the server should already be running and you can access the interface with http://localhost:3344 or http://<ip address>:3344 if you are running it on a remote linux computer.

Sign In or Register to comment.