Compile error for default firmware

Trying to compile the factory supplied firmware for my Melzi 2.0 board I3 Prusa printer.
I'm using ArduinoIDE Version 1.6.9 with Repetier 0.92.9 - I got the copy from github as well as the board data for the Sanguino board from github. Those are all the latest stable versions (Near as I can tell). I still get the :

The newer version of the firmware seems to use many new vairables that are of course not defined in the factory supplied firmware. So far I have managed to add these #defines for a lot of those variables but have found an issue that stumps me. (I am not a programmer so am easily stumped). I get hese arror messages:

Arduino: 1.6.9 (Windows XP), Board: "Sanguino, ATmega1284 or ATmega1284P (16 MHz)"

In file included from sketch\Repetier.h:198:0,

                 from sketch\BedLeveling.cpp:107:

Configuration.h:200: error: expected unqualified-id before numeric constant



exit status 1
expected unqualified-id before numeric constant

The line highlighted in the code is:

These lines are identical in the old configuration.h file and the new one generated from a configuration session on line. Until now, the compile failed because of a missing #define in the old file. Neither file has a declaration for HEATER_1_PIN so what's up?


  • Check pins.h lin e893 whcih looks like

    #define HEATER_1_PIN 14 // (bed)
    and modify it to
    #define HEATER_1_PIN 14

    Arduino ide 1.6.9 and newer handle comments in macros differently then before which causes such problems
    and I guess your code uses that one line I forget to remove the comment.

  • That solved this issue. Onward to the next one.
Sign In or Register to comment.