Show Filament button doesn't work

Hi, I'm on Windows 10 and "Show Filament" button doesn't work.
If I enable it nothing change.
"Show Travel" button works, but it's not useful without filament preview:


Can you help me?

PS: I tried on two different computer, with version 1.6.0 and 1.6.2, it doesn't work on both.


  • From the preview I assume there is no extrusion in your gcode. Maybe just selected wrong gcode flavour so it is not E but maybe A being incremented. Look into your gcode and then you will know.
  • edited August 2016
    I tried with custom stl files and with stl files from thingiverse.
    All generate the same result after slicing.  
    If I start printing generated gcode it prints successful for all files, it's only the show filament preview that doesn't work.
  • It does not depend on the stl you use if the slicer setting is wrong. Check the gcode if it contains G1 moves with E or not. Only with E you should see filament. "A" could print with some older firmwares and some others. Also make sure you have filament visualization on medium or it will look like moves if it is on "Simple".
  • Yes, I've the E moves in gcode:

    M92 E865.888000
    M109 S185.000000
    ;Sliced C:\Users\Genky\Downloads\4511gearsR.stl at: Tue 16 Apr 2013 19:29:49
    ;Basic settings: Layer height: 0.2 Walls: 2 Fill: 20
    ;Print time:     0:58
    ;Filament used:     2.12m    26.46g
    ;Filament cost:  Unknown
    G21        ;metric values
    G90        ;absolute positioning
    M107       ;start with the fan off
    G28 X0 Y0  ;move X/Y to min endstops
    G28 Z0     ;move Z to min endstops
    G92 X0 Y0 Z0 E0         ;reset software position to front/left/z=0.0
    G1 Z15.0 F600 ;move the platform down 15mm
    G92 E0                  ;zero the extruded length
    G1 F200 E3              ;extrude 3mm of feed stock
    G92 E0                  ;zero the extruded length again
    ;go to the middle of the platform (disabled, as there is no need to go to the center)
    ;G1 X?machine_center_x? Y?machine_center_y? F9000
    G1 F9000
    G1 X74.6 Y102.87 Z0.36 F9000.0
    G1 F2400.0
    G1 E3.0
    G1 F9000.0
    G1 X76.939 Y108.713 Z0.36 F1500.0 E3.2093
    G1 X79.917 Y111.69 E3.3494
    G1 X83.178 Y114.137 E3.485


    These are the settings:
  • That gcode is ok and settings are also ok. 

    What I see is that your "travel moves" have not the color for travel moves from your config. So could it be that this is the color of your extruder and thus the filament just only with simple visualization? Have you had a look in the log if visualization was changed for some reason? At least during print this happens if frame rate gets too low.
  • edited August 2016
    No, It's because the first screenshot is from a pc and the settings screenshot is from the other (I've the problem on two different computers as I told in first post).
    The color of travel move it's ok, I tried also to change filament visualization options, quality Reduction etc but nothing change.
    I also don't see filament preview during printing :(
    In log visualization there aren't records about graphics problem (only slic3r processing and standard commands).

    Does exists other "internal" log file to check?

    PS: these 2 computers have core i5 with 8gb of ram and 16gb of ram, integrated graphic card and dedicated graphic card.
  • Can you provide a sample gcode for testing. Also it is ok it might contain something confusing the visualization we don't know about.
  • edited August 2016
    It doesn't matter which gcode I use. I tried with many stl files, also many gcode generated 1 year ago with old versions of repetier (when it worked).

    This is one of many generated with old versions and that isn't work anymore:

  • I don't know if I explained right, but the program works, every gcode file is generated and printed correctly. The problem is "only" the filament preview. :)
  • I understand that. Tested you gcode and it worked perfect except
    G92 X0 Y0 Z0 E0         ;reset software position 
    confused my display since y homing is y max for my printer and that shifted everything outside. It is also absolutely unnecessary since you homed all axis so offsets are 0 anyway. But even that did not make it fail.

    After some testing I found out that if you set Printer Settings->Printer Shape->Printer Type to CNC Router this would happen since it is then a router not extruding. Could it be that you have not selected cartesian printer here?
  • Yeahhhh I changed Printer Type and It works!!!! Thanks a lot :D :D

  • edited August 2016
    I just tested that PCB gcode file generated with eagle is shown correctly only with CNC Router mode:

    At the same time, if I want to see a filament preview for a object to print I need to switch the Printer Type.

    Maybe this thing could be more clear? If I'm in cnc mode and load an object to print I should see a warning. At same time if I load a PCB and I'm in Classic printer mode I should see a warning that ask me to switch the printer type.

    Maybe this thing doesn't happen to lots of people but we have a powerwasp that can extrude or mill so this error can happen :)
    Also, in both types I can extrude object or mill PCB and It works, so I don't understand a lot the difference in filament preview behaviour.

    Thanks a lot anyway for the support! ;)
Sign In or Register to comment.