Y-axis center is off

I tend to use Slic3r more than the other 2 slicers. regardless of which slicer I use, if I place the object to be printed on dead center of the bed (200x200) in the software, it always prints the y axis about 25-30 mm off-center, (away from Y=0). Where pray tell do I get the software to recognize what I have for center?


  • SO your bed is 200x200 but where is nozzle when you home y? is it at edge or not over the bed? I guess you need to move to Y=25 to get over bed, so your center would then 135. So bed fron must be set to 35 in host and ymax to 235 in this example.
  • I think I know what you are referring to. When I home Y, the bed heads away from the front of the printer till it hits the physical end stop. I measured from the tip of the extruder to the edge of the bed and it is 20mm. Is that what is throwing me off? I need to tell the setup of the printer that it is 200mmx200mm, but the start position is +20 and the and the end is 225. The light went bright there.


  • OK, now I am confused again... LOL

    I know I am missing something very fundamental, and it is making me mental!

    I measured exactly the middle of the 200x200 bed and marked it on the blue tape. I KNOW where the center of the bed is.

    I created a cross object (X marks the spot) and opened it with Repetier-Host application. Using the picture area I placed the object directly over the Center indicator on the display.  So, theoretically, when I print it should be in the middle of the bed. 

    I changed the printer setting to +20 by changing the setting button up near the "EASY BUTTON" I selected the Printer tab and there on the screen is a "Park Position" for X, X and Z. I put the value 20 into the Y entry area.

    This did not help. It still printed 20 mm off center.

    I then went into the Slic3r Configuration and under Printer setting, entered a -20 into the y-axis. Now the picture diagram showed the extruder at the position of where it physically is at when I home the printer.

    Saved changes, re-sliced object and it still showed that it was in the center of the print bed. Same thing, it printed 20 mm off. Same spot as before.

    So for grins, I changed the value of -20 to +20 on the Slic3r Configuration. Now the y axis start is above the box in the display.  Printed again and it printed in the same spot again.

    So I looked into the g-code, and it is printing the number for the y axis is exactly where it is printing. So the printer is going to where it should (per the g-code). Somehow, my 20mm offset has got to be added to the g-code so that it prints in the direct center. How do I do that?

    Thanks, with a smile,


    BTY, I changed everything back to 0 both in the printer setting and the Slic3r Config. awaiting your suggestion.
  • Park position does not change coordinates, so that has no effect. You should do as I described. In host printer settings set bed front to 25 and increase ymax to 225. Now host shows bed at different position so y=125 is your center. Alternatively if you are using repetier-firmware you can force the printer to back 25mm after hitting y endstop so it always starts y = 0 over the bed. In config tool you define this in "Endstop distance after homing".
  • OK, I got it resolved. I forgot to make the ymax 225. Phew, Thanks for your assistance!
Sign In or Register to comment.