Setting the WRONG temps in G-Code

I thought I screwed something up, I am NOT sure what is going on as I have compltetely uninstalled, wiped out, and re-installed Repetier Host on my computer again... And this is was continues..

I have my ABS temps set for a 110c bed, and 230c extruder. All is good, but when I slice an object the g-code write and M190 to S50, M104 to S200 and M109 to S200. So my temps end up wrong. I try to print... and yep.. wrong temps are set. I try to print using OctoPrint... same shit.

If I edit the g-code to be M190 S110, M104 to S230, and M109 to S230..... ALL WORKS.

Has Anyone else had this issue?? And if so.. how did you fix it?

thank you,


  • I have tried again, and again. Updating the firmware, updating the EEPROM, updating the Software on my computer, and even reinstalling the software on the OctoPrint server to see if THAT made any changes.. Nothing. Its still dropping the bed to 50c and the extruder to 210c... Im not liking this very much at all.
  • Since you already said it is in your gcode why do you expect it to change? You need to change the slicer configuration which is where the temperatures got inserted.
  • It was the slicer config that was the issue. I spend a good 4 hours on this last night. The Cura slicer was not accepting anything other then the default profile. Even though I selected my own profile for the slicer it would revert to the default settings. I actualy had to change the DEFAULT profile settings to match what I wanted for it to work. But ONLY the temp settings. Everything else it would pull from my own filament and printer profiles.
  • Just tried it and worked as expected. Are you using the latest version? In older version there was a bug that it did not always select the visible selection.
Sign In or Register to comment.