Problem to start printing

Hi, I have a 3d printer that works with arduino Mega and ramps 1.4. The arduino is connected by USB to a Raspberry PI. The raspberry has repetier server installed. The problem is when I put some file to print, the printer make homming in all axes, turns on the heatbed and the hotend, but when it reaches the temperature, It does not start to print. I don't know why that appends. It was working well. Arduino mega has Marlin firmware. I check that the buffers were the same that the repetier Server. I try with repetier Server 0.70 and 0.75b. I also change my raspberry PI B for a raspberry PI 3. I thought the problem was that the heatbed is too slow, but when I try with a lower temperature for PLA, I doesn't work too. 
What can it be? 


  • Your print contains M109 and M190 to wait for temperatures. Sounds much like these never finish waiting for temperature to stabilize. You can normally relax the stop condition allowing +/-2°C and not wait for x seconds inside corridor.

    As a test remove the M109/M190 lines from your gcode and preheat printer. Then it should print.
  • I've tried changing the firmware to repetier firmware. Now it heats up, start printing but, after a couple of layers, the heatbed and hotend turns off, the extruder stops printing but it keeps doing the movements in x, y, z. What can it be?
  • If you log you would see a decoupled message I guess. If you have a lcd display for printer you should see dec for one of the extruders. Log contains more information on which extruder and why.

    Decouple test is a safety feature that detects if the thermistor got loose by observing temp. change while heating. As extruders have different speed, default values do not work on all. Especially if you enable fan this can cool extruder on turn on which is then detected as decoupled. So you need to relax the parameter, meaning decoupling time and allowed temperature deviation. 
  • edited July 2016
    I was watching the printer and I found that the layer fan start at first layer, even when I turn off in the first layers in the slicer.This is why the hotend gets cold and the protection and repetier stops printing. Is there any way to turn off and let the slicer to control the Fan? Thanks
  • Fan is controlled by slicer! You only need to allow more temp. deviation for decouple test and even a fan on will not hurt then. It's just that the fan is cooling the wrong parts as well (or it is by design, but those extruders normaly have a separate fan for extruder cooling).
  • Ok ok. I will try changing the design of the fanduct thank you very much!!
Sign In or Register to comment.