Y Axis Wandering

Hi All,
I am new here, but not to 3D printing.  I have been using 3D printers for years at my work.  I decided to build one for myself and made a huge mistake buying a Chinese crap... Now, I have tons of problems.  I am not really sure if this is a good place to ask.
I am using Repetier Host and the Firmware on my i3 clone.  Here are two major problems I am facing now:
1. SD card does not read.  It detects the card, but shows no files in there.  I tried with 6 different cards and formatted them with FAT32.  I used gco extension with 8 characters max.  No luck.
2. When the printer prints, it wanders off to right side (Y axis) evertime it hits 30+ layer.  Somehow, motor does not want to pull the extruder back. It keeps going to right until it hits the end or I hit Reset button.  It makes that every time.  I could not get any finished object so far.  I tried different USB cables on different USB port combinations, result is the same.
I appreciate for any lead.


  • Sorry, actually it is the X Axis, not Y.
  • What firmware?

    I assume your x endstop is left. So wandering to right is a sign for triggering on some moves preventing left move. This is normally cross talk to endstop from motor current. Could also be something else like loosing steps or slipping pulley, but one sided moves are normally a result of endstops. You could disable endstop check during print as a resolution or twist/shield endstop cable.

    sd card is hard to say. firmware/cable/other hardware issues...
  • Hi,
    Thank you for the reply.
    I am using 0.92.9 firmware.
    And, yes... My endstop is on left side.  I will try to separate the endstop wires from the cable spaghetti.  I will also check how to disable endstop check...
    I checked, double checked the slippage, but I am sure no issues there.
    Interestingly, I cannot paste an image to this forum? 
  • Stupid me... I pulled the cable, untangle, and pushed back to its slot. Suddenly, I saw smoke coming out from the circuits.  Well, I think I fried something... I guess I have to buy a new set.
    Thanks anyway.
Sign In or Register to comment.