I can't get Rep Server installed- help please

I have a raspberry pi 2 b with NOOBS installed.
I can't get server downloaded. I've tried a number of different commands that I found online and none have worked.  They include commands that start with sudo apt-get, wget, sudo apt-get install, sudo wget, etc. etc..
One of the commands I tried that seemed Iike it should have the best chance of working was;
 sudo apt-get install Repetier-Server-0.75.1-Linux-2.deb
It returns that it's;
 unable to locate package Repetier-Server-0.75.1-Linux-2.deb
 couldn't find any package by regex 'Repetier-Server-0.75.1-Linux-2.deb'
one other question- what directory should I be in when I download it? Root or download?
I really don't want to learn programming language. I just want to get server installed.
Help, please!


  • wget http://download.repetier.com/files/server/debian-armel/Repetier-Server-0.75.1-Linux.deb
    sudo dpkg -i Repetier-Server-0.75.1-Linux-2.deb

    should do the trick.
  • No joy. Get:
    wget: unable to resolve host address 'download.repetier.com'

    Should I be trying this from the root or download directory?
  • Seems like the problem is no connection to the internet.

    Are you using the pi via SSH or like a normal computer with keyboard and monitor?

    This site is a good step by step guide and covers both.

  • Duh- you're right. Forgot I was trying from work and didn't set up wifi.
    So I got the file downloaded and installed (but I did have to change the path for the dpkg command that's listed above).
    Thanks for the site link but I had already checked that one out.  It doesn't say what directory to download to and the paths are wrong. For the average person it becomes daunting.
    Anyway, thanks to both for the help.
Sign In or Register to comment.