Server won't start - .net error 1026

edited June 2016 in Repetier-Server
I had this installed on an old laptop and was working fine. Then the laptop died, so reinstalled on a fresh install of windows. Now when I try to start the server, I get the following in the event log:
Application: RepetierServerStarter.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException
   at System.ServiceProcess.ServiceController.GenerateNames()
   at System.ServiceProcess.ServiceController.get_ServiceName()
   at System.ServiceProcess.ServiceController.GenerateStatus()
   at System.ServiceProcess.ServiceController.get_Status()
   at RepetierServerStarter.Program.Main(System.String[])
Followed by:
Faulting application name: RepetierServerStarter.exe, version:, time stamp: 0x54e1da7d
Faulting module name: KERNELBASE.dll, version: 6.3.9600.16656, time stamp: 0x5318237f
Exception code: 0xe0434352
Fault offset: 0x00000000000043c8
Faulting process id: 0x1484
Faulting application start time: 0x01d1bc1892941bdb
Faulting application path: C:\Program Files (x86)\Repetier-Server\bin\RepetierServerStarter.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: d04c937a-280b-11e6-8251-74de2b7a2588
Faulting package full name: 
Faulting package-relative application ID: 

I verified the .net installation and reinstalled the server. Any other ideas to try?  Thanks!
Windows version 8.1
Server version 0.75.1-win32 (redownloaded today)


  • The server runs as a service. So what RepetierServerStarter.exe does is starting/stopping the service. You can do so as well in windows service manager and server should run anyway after install/reboot if not set to start manually. So first check if localhost:3344 shows the server in your browser.

    The other question is of course why the starter itself crashes, which is what your logs show. The program needs admin privileges and when I start it, it asks for them. Does that also happen for you? 
  • localhost:33444 does NOT show in the browser, that's how I went looking for what the problem was.  I've tried running the start server as admin. No luck. I haven't tried starting the service itself. I'll try that next
  • I did not see a service in services.msc that was named repetier or anything like that. I looked at the shortcut and it runs:
    "C:\Program Files (x86)\Repetier-Server\bin\RepetierServerStarter.exe" start
    I opened an administrative command prompt and ran this and got no feedback. localhost:3344 still wasn't responding, and the same errors were in the windows logs.
  • Double-clicked on the C:\Program Files (x86)\Repetier-Server\bin\Repetier-Server.exe
    and got:
    The program can't start because api-ms-win-crt-runtime-l1-1-0.dll is missing
    The google tells me that is because The problem is that the KB2999226 (Universal CRT) which is part of the Visual C++ Redistributable for Visual Studio 2015 failed to install.

    All good now.
  • Thanks for the update. A missing dll is surely a problem here. Now I at least know what to look for if others have the same problem.
Sign In or Register to comment.