Scaling isn't honored

When I design objects in Sketchup, I draw everything at x1000 and display units in meters. This gets around the issues of resolution limits in Sketchup.
Export to an STL is done with export units set to mm. Cura correctly interprets the object's size.
When I tried to use Repetier Host with import units set to mm, the object imported as though it was in meters rather than in mm. When I set the import units to meters, the object cannot be found on the screen.
Scaling the object within Repetier results in the object being the correct size, but then the offset information shows tens of thousands of mm. Repetier host also locks auto-placement as soon as I try to load a second object on the platform because it considers the platform to be over-filled.
So, am I doing something wrong or does Repetier Host not honor the units specified by the imported STL?


  • Per definition STL has no units. So it is not possible to see the correct scale. If you export wth factor 1000 from meters that should be ok to import it as mm meaning do not scale like all other objects. 

    So there might be the possibility that sketchup does something undocumented/unknown in the generated stl. Can you send a simple example with real dimension info so we can test what the problem is?

  • Here is a link to one of the files pulley slide 3_fixed.stl?dl=0

    The actual object is 48.78mm x 47.03mm x 35.43mm. As I indicated, this object does load and print properly with Cura 15.04.

    Here is an image of the object.

  • Ok, I see it states units are mm in reserved comment block. But it has a size with factor 1000 in reality. Other software also scales it as 48780mm. The fact that cura doesn't is I think a clever function that scales such objects by factor 0.001 on import if it exceeds a few meter, assuming scale is wrong. So the question is more why sketchup scales it by 1000000 instead of 1000. Have you tried exporting without unit change if it fits?

    I see the problem with autoposition as well after scaling. So that seems a host bug I will investigate. I even think about adding such a sizing error detection as well.
  • I tried exporting the object in Model Units (meters) and Cura automatically re-scaled it to mm.
    Strangely, Repetier Host also re-scaled or interpreted it as mm!
    This was true only when import units was set to mm.
    Here is a link to the Model Units file pulley slide 3_model units.stl?dl=0
  • That file had units = mm for real. No scaling required.

    I have now added a detection for scaling 1000 to high for next release, so we then can also import false scaled files:-) But now you know how to export correctly, so that is not required for you.
Sign In or Register to comment.