Preview placement after slice at 0,0

edited May 2016 in CuraEngine

After upgrading from 1.6.0 -> 1.6.1 my previews after slicing with Curaengine are placed and printed at 0,0 in the lower left corner.
Printing at 0,0 is impossible!
Changed different settings in the printer configuration menu without success and made a fresh install with deleting .mono and .local/share/RepetierHost directories.

The Problem still exist.


  • Updated Cura to 15.04.5, problem still exists.
    Sliced with slicer, object is correctly placed in midposition.
  • Please only used bundled curaengine. Cura may use a incompatible engine.

    If you see it is called like this
    09:40:07.401 : CuraEngine command:C:\Program Files\Repetier-Host\plugins\CuraEngine\CuraEngine.exe -p -v -c "C:\Users\littwin\AppData\Local\RepetierHost\cura.ini" -s posx=0 -s posy=0 -o "C:\Users\littwin\AppData\Local\RepetierHost\composition.gcode" "C:\Users\littwin\AppData\Local\RepetierHost\composition0.stl"

    setting bed position plus we write stl at right place and do not use original stl files. For me it stil works with 1.6.1- But all files must be writable for your user.
  • Thanks for your reply.

    I deleted all directories and config's like .cura, .local/share/Repetier, .mono and the unzip directory.
    I start repetierhost 1.6.1 get the default preview and slice it without configuring my printer, just use CuraEngine instead of Slicer.

    The Objekt ist placed in the lower left corner, with 50% outside of the printroom/bed.
    The Log:
    16:26:15.785 : CuraEngine command:/home/eike/Downloads/system_sparkcube/RepetierHost/plugins/CuraEngine/CuraEngine -p -v -c "/home/eike/.local/share/RepetierHost/cura.ini" -s posx=0 -s posy=0 -o "/home/eike/.local/share/RepetierHost/composition.gcode" "/home/eike/.local/share/RepetierHost/composition0.stl"
    16:26:15.795 : <CuraEngine> Cura_SteamEngine version 14.09
    16:26:15.796 : <CuraEngine> Copyright (C) 2014 David Braam
    16:26:15.796 : <CuraEngine> This program is free software: you can redistribute it and/or modify
    16:26:15.796 : <CuraEngine> it under the terms of the GNU Affero General Public License as published by
    16:26:15.796 : <CuraEngine> the Free Software Foundation, either version 3 of the License, or
    16:26:15.796 : <CuraEngine> (at your option) any later version.
    16:26:15.796 : <CuraEngine> This program is distributed in the hope that it will be useful,
    16:26:15.796 : <CuraEngine> but WITHOUT ANY WARRANTY; without even the implied warranty of
    16:26:15.796 : <CuraEngine> MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    16:26:15.796 : <CuraEngine> GNU Affero General Public License for more details.
    16:26:15.796 : <CuraEngine> You should have received a copy of the GNU Affero General Public License
    16:26:15.796 : <CuraEngine> along with this program.  If not, see <>.
    16:26:15.796 : <CuraEngine> Default config 'default.cfg' not used
    16:26:15.796 : <CuraEngine> Config(/home/eike/.local/share/RepetierHost/cura.ini):L13: Failed to set 'skinSpeed' to '45'
    16:26:15.796 : <CuraEngine> Failed to read config '/home/eike/.local/share/RepetierHost/cura.ini'
    16:26:15.796 : <CuraEngine> Loading /home/eike/.local/share/RepetierHost/composition0.stl from disk...

    What can I do? I use Ubuntu 15.10 latest patches installed.
    And Cura from Ultimaker is installed but not used, because I also have an Ultimaker.
  • I didn't find any solution till now, any hints?
  • What we do is writing /home/eike/.local/share/RepetierHost/composition0.stl positioned where it should be sliced.  -s posx=0 -s posy=0 tells the engine not to shift around the stl file.

    Looking at the log I think
    16:26:15.796 : <CuraEngine> Config(/home/eike/.local/share/RepetierHost/cura.ini):L13: Failed to set 'skinSpeed' to '45'
    16:26:15.796 : <CuraEngine> Failed to read config '/home/eike/.local/share/RepetierHost/cura.ini'

    is the real problem. So you better look into the ini file and check what might disturb cura here. If the ini file is ignored no body can say what values it takes. For a working version it looks around skinSpeed like this

    infillSpeed = 43
    skinSpeed = 36
    inset0Speed = 33
    insetXSpeed = 33

  • Same here.
    Repetier Host 1.6.1 with bundled curaengine, Ubuntu 14.04.

    $HOME/.local/share/RepetierHost deleted, $HOME/.mono/registry/CurrentUser/software/repetier deleted, repetier install dir deleted, gunzip 1.6.1, did sudo ./, adjusted owner and execute rights of just created .desktop file, copied it to desktop. Launched Repetier Host.
    Tried slicing of example object with all default settings (hit only 'Slice with CuraEngine')
    Got error L13: Failed to set 'skinSpeed' to '45' and center of sliced object placed at 0,0.

    So what disturb curaengine on *out of box* Repetier Host?
    I agree the real problem is curaengine ignoring .ini file due to fail on line 13. But how it can be adjusted?
  • What does the ini file look like that gets created? I think the solution lies in analysing the wrongly created content.
  • I do have the same problem from a long time but I am able to find this discussion just now.
    My log show the same error in the ini file and the same thing: the object sliced with cura is always on 0,0 after the slice.

    I've checked my permissions and are fine to me, I've also set cura.ini and composition* to 777 just to be sure.
    They have the same permissions of slic3r, but slic3r works.

    Here's the content of cura.ini

    [blackman@Vega Repetier]$ cat cura.ini
    layerThickness = 200
    initialLayerThickness = 300
    filamentDiameter = 1750
    filamentFlow = 100
    extrusionWidth = 400
    layer0extrusionWidth = 400
    insetCount = 2
    infillOverlap = 15
    initialSpeedupLayers = 4
    initialLayerSpeed = 30
    printSpeed = 40
    infillSpeed = 60
    skinSpeed = 30
    inset0Speed = 30
    insetXSpeed = 40
    moveSpeed = 150
    fanSpeedMin = 50
    fanSpeedMax = 100
    supportAngle = -1
    supportEverywhere = 0
    supportLineDistance = 2666
    supportXYDistance = 700
    supportZDistance = 150
    supportExtruder = -1
    retractionAmount = 4000
    retractionSpeed = 40
    retractionMinimalDistance = 1500
    retractionAmountExtruderSwitch = 16000
    retractionZHop = 0
    minimalExtrusionBeforeRetraction = 20
    enableCombing = 1
    multiVolumeOverlap = 0
    objectSink = 0
    minimalLayerTime = 5
    minimalFeedrate = 10
    coolHeadLift = 0
    perimeterBeforeInfill = 1
    extruderOffset[0].X = 0
    extruderOffset[0].Y = 0
    fixHorrible = 1
    fanFullOnLayerNr = 2
    supportType = 0
    infillPattern = 0
    sparseInfillLineDistance = 4000
    downSkinCount = 3
    upSkinCount = 3
    skirtDistance = 3000
    skirtLineCount = 1
    skirtMinLength = 150000
    gcodeFlavor = 0
    spiralizeMode = 0
    enableOozeShield = 0
    autoCenter = 0
    startCode = """
    ; Default start code
    G28 ; Home extruder
    G1 Z15 F100
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    M190 S50
    ; Activate all used extruder
    M104 T0 S210
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    M109 T0 S210
    endCode = """
    ; Default end code
    ;G1 X0 Y0 Z130 ; Get extruder out of way. Uncomment to use!
    M107 ; Turn off fan
    ; Disable all extruder
    G91 ; Relative positioning
    G1 E-1 ; Reduce filament pressure
    M104 T0 S0
    G90 ; Absolute positioning
    G92 E0 ; Reset extruder position
    M140 S0 ; Disable heated bed
    M84 ; Turn steppers off
    preSwitchExtruderCode = """

    postSwitchExtruderCode = """


    AND if I delete cura.ini it gets created exactly the same again

    Please HELP !!

  • The cura.ini gets created by the host as option file for cura. Looks good so no real reason for CuraEngine to complain from what I see. Are you using 32 or 64 bit version?
  • I have the same problem on another linux pc, which I have at work and it's not configured for printing. I use the stock options just to try some slicing. My first pc has repetier 1.6.1 and the second one 1.5.6
    Both are on Fedora 22-23, 64 bit machines
    Default CuraEngine with Repetier but I have tested also other version.

    While exploring about your question I think I've found the bug.
    I have the Cura Plugin directory with CuraEngine CuraEngine32 and CuraEngine64. I assume that CuraEngine is a wrapper?

    If I delete CuraEngine and symlink directly the 32 or 64 bit filename, both works

    Directory RepetierHost/plugins/CuraEngine

    mv CuraEngine CuraEngine.old
    ln -s CuraEngine64 CuraEngine


    ln -s CuraEngine32 CuraEngine


    mv CuraEngine.old CuraEngine


    I had this problem for months :-|
    I am going to try this solution at home tonight to see if it works with the 1.6.1 too
  • CuraEngine is just a copy of CuraEngine32 or CuraEngine64 executed on So no wrapper. So normally I'd expect all 3 versions to work. I really need to test it as well. For me it is a debian linux installation.
  • I have tested also my other fedora, this second one is a fedora 22 with repetier 1.6.1
    The "hack" works also there.

    In my system it does not looks like a copy of the two, the file size is different..

    $ pwd
    $ ls -l
    totale 7080
    lrwxrwxrwx  1 blackman blackman      12  7 giu 10.04 CuraEngine -> CuraEngine64
    -rwxr-xr-x. 1 blackman blackman 1965872  2 lug  2015 CuraEngine32
    -rwxr-xr-x. 1 blackman blackman 2535136  4 lug  2015 CuraEngine64
    -rw-r--r--. 1 blackman blackman  198144 23 set  2015 CuraEngine.dll
    -rwxr-xr-x. 1 blackman blackman 2531049  4 lug  2015 CuraEngine.old

    $ diff CuraEngine.old CuraEngine32
    I file binari CuraEngine.old e CuraEngine32 sono diversi (different)
    $ diff CuraEngine.old CuraEngine64
    I file binari CuraEngine.old e CuraEngine64 sono diversi

    I am going to check the and report.

    Thanks for this amazing software.

  • I see. The plugins copy the CuraEngine file.
    The point is that I never launched it and looks like if you just download the precompiled version it's broken.
    Perhaps this should be checked in repetierHost lanuch script? I am discovering just now it was written on the README file...

  • blackfede said:
    I see. The plugins copy the CuraEngine file.
    The point is that I never launched it and looks like if you just download the precompiled version it's broken.
    Perhaps this should be checked in repetierHost lanuch script? I am discovering just now it was written on the README file...

    Happened to me too from the latest version precompiled, running the script solved the errors. Maybe use the CuraEngine64 as a default instead of CuraEngine?. 
  • I'm working on a 64 bit appimage so host installation becomes adding one file that contains all dependencies including mono, perl and slicers.
Sign In or Register to comment.