Install error on Ubuntu 14.04LTS 64 bit

I get the following error message when trying to install on a new Ubuntu machine.

error while loading shared libraries: cannot open shared object file: No such file or directory

I thought maybe the library wasnt installed so I ran: sudo apt-get install libstdc++6 but it showed that it was up to date. I'm not very knowledgeable about Linux so maybe its a simple issue I'm doing wrong. Any help would be much appreciated.

Here's the full install log:

repetier@repetier-desktop:~/Downloads$ sudo dpkg -i Repetier-Server-0.75.0-Linux.deb
(Reading database ... 199494 files and directories currently installed.)
Preparing to unpack Repetier-Server-0.75.0-Linux.deb ...
Uninstall Repetier-Server
 * Stopping Repetier-Server rsd                                          [ OK ]
Unpacking repetier-server (0.75.0) over (0.75.0) ...
Setting up repetier-server (0.75.0) ...
Install Repetier-Server
You may see warnings about groups. These can be ignored.
The user `repetierserver' is already a member of `tty'.
adduser: The group `intserial' does not exist.
adduser: The group `ugpio' does not exist.
 * Starting Repetier-Server rsd                                                 /usr/local/Repetier-Server/bin/RepetierServer: error while loading shared libraries: cannot open shared object file: No such file or directory
dpkg: error processing package repetier-server (--install):
 subprocess installed post-installation script returned error exit status 127
Processing triggers for ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Errors were encountered while processing:


  • If I call 
    ldd /usr/local/Repetier-Server/bin/RepetierServer

    i get
   =>  (0x00007ffc993c0000)
   => /lib/x86_64-linux-gnu/ (0x00007fa33d540000)
   => /lib/x86_64-linux-gnu/ (0x00007fa33d320000)
   => /lib/x86_64-linux-gnu/ (0x00007fa33d118000)
   => /usr/lib/x86_64-linux-gnu/ (0x00007fa33ce10000)
   => /lib/x86_64-linux-gnu/ (0x00007fa33cb88000)
   => /lib/x86_64-linux-gnu/ (0x00007fa33c970000)
   => /lib/x86_64-linux-gnu/ (0x00007fa33c5e0000)
            /lib64/ (0x00007fa33d748000)

    showing which libraries the server uses and where it finds them. Try this with your linux and check if that file is there and readable for everyone.
  • Thanks repetier for pointing me in the right direction. It turns out there was no in /usr/lib/x86_64-linux-gnu/
    even though was installed. After doing a bit of
    searching I found that installing the 32bit version fixed it. So in case
    anyone else has this issue here's what I had to do to fix it

    sudo apt-get install lib32stdc++6
  • Why didn't you install the 64bit server version if you have 64bit? We have both 32 and 64 bit versions for intel linux.
  • Good question I just read this
    " intel32: libc 2.19 like used in Ubuntu 14.04LTS
    amd64: libc 2.13 like used in Debian Wheezy "
    I'm not much of a Linux user I just knew I had Ubuntu 14.04LTS so I went with that. Would the amd64 been a better choice?
  • Now that it is working it makes not much difference. Both work at same speed and memory range is not an issue. I guess 64 bit would maybe do some math stuff faster. 
Sign In or Register to comment.