localhost refused to connect and no server menu tab Please help!

I installed the latest version of repetier host (1.6.1), as well as server when prompted by installation. I opened the host to see that there is no server menu tab. I thought they may have removed it from 1.5.6 to 1.6.1, because my other computer with 1.5.6 does have the server tab. I try to open the server (with the other server stopped and cpu on sleep mode) manually by going to programs->repetier server-> start server. It shows a loading mouse, but opens no gui. I thought that maybe it has no front-end other than web, so I tried to go to http://localhost:3344/ and I get the following error. 

This site can’t be reached

localhost refused to connect.


So, in my attempt at debugging, since the other PC works with 1.5.6 , I tried to install 1.5.6. I completed the install and it still has no server menu tab in the host. I don't know what else to try.image


  • My guess is that installing the new server version failed after deinstalling the server. So host does not see the server service and hides the menu entry and that also explains the not working localhost:3344

    Solution would be to reinstall 0.75 and see if localhost:3344 then works. In that case host should also show the server menu on startup.
  • Still having the same issue. I uninstalled and installed 0.75. When the install finished it automatically loaded the localhost page which still failed. I checked in the host and it still has no server menu. Any ideas? Should I copy the C:/Program Files/repetier folders for servre and host from my working computer and try that?
  • I am running a x64 system on the non-working and x32 on the working. Should that have any effect?
  • No 64 bit is fine. I develop and compile it on 64 bit myself. 

    You could try this:
    1. Open cmd.exe as admin
    2. Go to repetier server installation with cd
    3. call
    RepetierServer /registerService /startup=automatic

     that should register the server so it appears and starts automatic. This is done by the installer but seems to have failed. Maybe it works if you do by hand or you see at least a error message why it does not work.
  • I get the following exception. 

    System exception: cannot open Service Control Manager
  • I was able to open that RepetierServer.exe by double clicking though and it seems that it started because the localhost page loaded. I'll let you know if it has any issues.
  • By the way, thank you so much!!!
  • If you start it by clicking on it you start it in stand alone mode, not as background daemon. Except this it works the same.

    The main question is why it can not open your  Service Control Manager? That is part of your windows and the reason why it did not succeed. So googling for that problem might solve the install problem on your windows. Could it be a missing permission?
  • Possibly. It seems to be working well just with the RepetierServer.exe page so that solves my problem. I don't mind seeing the command line rather than a gui as long as it works. One final question, is it possible to print from the sd card when connected remotely to the server, or should I start the print in host and open server? 

    Thank you for the help and your wonderful software. I will be sure to buy the mobile app and donate to your worthy cause.
Sign In or Register to comment.