Dual extrusion - wrong first layer


I am starting to play with dual extrusion and have found a minor annoyance with Curaengine. The first layer always seems to want to print with the second extruder, even though the first 8 or so layers are all the first extruder. Am I missing a setting somewhere?


  • It also not hounering the extruder offsets beyond the first layer

  • You do set all offsets to 0 in curaengine and host. Only define extruder offsets in repetier firmware.

    As far as I know CuraEngine always swaps extruder at end of layer and assumes T0 active on first layer. So maybe adding T0 in start gcode would help here.
  • The slicer assumes that T0 is the current extruder being used by the printer, but the printer will remember the last used extruder from the previous print until reset or power cycled.  I added a tool change in my end g-code to set the extruder back to T0 if previously used extruder was T1.

    {IF_EXT1}T0 ; Force reset to first extruder

    The above command in your ending g-code setting will check if second extruder was active and reset to extruder 1.
Sign In or Register to comment.