Turn Off Repetier-Server Rendering

Hello,
I am having trouble running Repetier-Server on the Raspberry Pi
Whenever the Repetier-Host starts a print one of the first things it does is request Repetier-Server render the model
This cause the Raspberry Pi to slow to a crawl and run out of resources to the point where it can't send print instructions fast enough to the printer causing a slow stuttering motion on the print head

Is there a way to disable Repetier-Server "Rendering"

I can only find settings to reduce quality in the "Global Settings area" not to turn it off completely

If I close the "Rendering" rendering window in Repetier-Host Repetier-Server will print flawlessly for hours on the Raspberry Pi
I don't really see the point of the server rendering the model when a host does it just fine

Can I delete a file on the server, i don't really care if i break the rendering.json
 

Comments

  • I renamed the file
    /usr/local/Repetier-Server/modules/server/data/renderer.json
    And it's back to being usable
  • Install server on your pc and setup connectivity in the pi server to use your pc as cloud computing server. Then your pc does all the long running jobs instead as long as it is online.

    The renderings are for the server frontend so you see what you are printing. If you upload first to models and wait until it is rendered that would also work.
  • After some thinking about it I thought the priority might be a problem. Checking my pi it shows that the server runs with priority 20 which is the lowest priority. If you set in /etc/init.d/RepetierServer the start command to

    start-stop-daemon --start --nicelevel -20 --quiet --oknodo -c $RUNASUSER:dialout --startas $DAEMON --exec $DAEMON -- $SERVER_OPTS
    it will start server with highest priority. That should give it the required time to render and print fluently.

  • edited July 21
    I bought the pro version because of the talk about using PC to do cloud computing and can not work out where these settings are ? 

    is it this section with the API keys etc ? 
    http://localhost:3344/#!/gsettings/connectivity


    the raspberry pi 2b still seems slow , I can import practically instantly on the PC but the pi is taking forever  ~80 files to go , I can see the server is using some CPU on the PC how ever 

    how ever I have no also noticed I can not import fast on PC now, plenty of compute power available , is their a que system that is slowing down multi tasking ? 

    as if I shutdown the pi , the PC then imports instantly again ... 


    testing with https://www.thingiverse.com/thing:2796048


    I can not find this file ?

    /etc/init.d/RepetierServer

    start-stop-daemon --start --nicelevel -20 --quiet --oknodo -c $RUNASUSER:dialout --startas $DAEMON --exec $DAEMON -- $SERVER_OPTS

    Linux Repetier-Server 4.19.118-v7+


    pi@Repetier-Server:/etc/init.d $ ls
    alsa-utils        cron     dphys-swapfile  hostapd            networking       ntp           pppd-dns      rsync    triggerhappy
    avahi-daemon      dbus     exim4           hwclock.sh         network-manager  paxctld       procps        rsyslog  udev
    bluetooth         dhcpcd   fake-hwclock    keyboard-setup.sh  nfs-common       plymouth      raspi-config  ssh      x11-common
    console-setup.sh  dnsmasq  haveged         kmod               nginx            plymouth-log  rpcbind       sudo     xrdp



  • Yes you define it in connectivity. There you add the ip/port/apikey of the pc to the list on the pi and then pi can outsource it to the pc if it gets green.

    To not get out of memory/cpu there is in deed a queue system so only one image at the time gets remdered. In trounleshooting tage you see what is currently getting computed.
  • Since you said when pi is down Pc is fast i guess you have assigned the connectivity the wrong way around so pc outsources rendering to pi.
  • I have computations turned off with the pi's API added 

    I have 128 threads available (AMD Ryzen Threadripper 3990X) 

    https://ibb.co/pykn5HY

    I am pretty sure it is que depth related because it is computing a task for another machine its sitting their twiddling its thumb using only 1 thread 

  • As i said server limits renderings to one at a time so using only one thread is ok. From settings they get computed on your pc if you Upload them on the pc. If pi outsources them is only visible in pi connectivity settings.
Sign In or Register to comment.