My extruder won't heat up

Ive tried everything. Every software version of repetier and still nothing . Its not my wire connector and I have voltage. I can manually set the temp on the extruder will printing. Also its not in dry run. Does anyone have any ideas for me to check? Also my g code says its telling to heat but nothing. Ive seen other people had this problem and fixed it but didn't come back and tell how they did that.
Here is my g code

Comments

  • ; generated by Slic3r 1.1.7 on 2016-02-20 at 08:57:38

    ; perimeters extrusion width = 0.50mm
    ; infill extrusion width = 0.70mm
    ; solid infill extrusion width = 0.70mm
    ; top infill extrusion width = 0.70mm

    G21 ; set units to millimeters
    M107
    M190 S105 ; wait for bed temperature to be reached
    M104 S255 ; set temperature
    G28 ; home all axes
    G1 Z5 F5000 ; lift nozzle

    M109 S250 ; wait for temperature to be reached
    G90 ; use absolute coordinates
    G92 E0
  • The code is ok, so it must be a firmware issue not a host problem. The question here is first how far does the code come. First it is waiting for bed to reach 105°C so does it happen?
    Does M104 work which is used when you heat manually. M109 will again wait for extruder to reach temperature.
  • Yes the bed reaches temp ok. Not sure what you mean by "does m104 work?
  • I mean does sending
    M104 S255
    heat the extruder.

    The thing is you need to verify if commands finish and what happens at which command. M190 for example might heat bed but never return because you have configured it to swing out very precisely and that never happens. Then the rest would never execute.
    M104 could enable extruder and M109 could disable it. Only when you know what fails you know where to look.

  • I'm having the same issue. It does look like when the nozzle reaches its temperature, the bed stops heating on mine. How do I fix that?

  • Extruder and bed temperature are not connected. If you send M140 S0 bed will stop heating of course.
    So check your gcode and analyse the log to see what goes on when it happens. It is either a command send or an error occuring and that is normally logged, also it depends on firmware you use.
  • I have same issue
    As soon as i connect to Ramps Board and open Repetier Host
    It shows extruder as 299.4 'c
    I haven't heated the extruder
    In log its showing as
    Disabled all heaters due to detected sensor defect...
  • Make sure to use the right sensor type. Wrong types can give totally wrong temperatures. Also make sure the analog input used is made for the sensor type. E.g. a PT100 sensor will not work at the thermistor input. Also as always make sure to use the right input pin number. The default names TEMP_0_PIN - TEMP_2_PIN are for thermistors. So if you have one of them try swapping cable until you see a temperature.
Sign In or Register to comment.