USB/Serial Communication Issues

I recently finished a new delta build w/ ramps 1.4 and firmware 0.92.8 and have been working my way through some kinks. I'm getting close to having everything ironed out but now I'm stuck on a usb/serial communication issue. Here are a few details of how I can generate the issue and some things I have tried:

* Printer is detected by computer and arduino drivers installs correctly.
* I am able to successfully connect to printer using Repetier Host, read ACK, and view/edit EEPROM, etc.
* As soon as I attempt any manual control (home axis, movement, heater, etc) the communication seems to halt and host often crashes.
* I have another delta build with essentially the same hardware (other than PSU and slightly smaller motors) connected to the same computer and do not have any comm issues.
* I was starting to assume interference from PSU or motors so without moving or altering anything I tried connecting the printer to my surface pro and it surprisingly connects fine and has no comm issues at all - I compared driver versions(, OS (win10), etc and couldnt find any obvious difference between the two computers.

Any ideas or something I may have overlooked?



  • Sounds like problems start as soon as you consume power, so maybe the PSU does not adjust fast enough to power changes. The serial connection chip on arduino seems to be quite sensitive. If you have a good 5V source from your PC that might fix the drop with power from USB. A active USB should provide 500mA, but some are better then others. As a counter test just switch your PSU with the one from the other printer.
  • I just wanted to say thanks for the quick and accurate response and report back with some additional information for anyone else who may come across this thread.

    I didn't swap the PSUs but I did get a powered USB hub and that solved the problem just as you suspected. I definitely appreciate the awesome software, firmware, and support Repetier provides.

Sign In or Register to comment.